Water pump replacement done, now high idle?

The G-Series Tuning Forum is the place to discuss G35/G37 performance modifications and mechanical repair.
tjrob2000
Posts: 56
Joined: Sat Jun 07, 2014 5:42 pm
Car: 2007 G35 sedan (journey)

Water pump replacement done, now high idle?

Postby tjrob2000 » Mon Jun 04, 2018 7:03 pm

Just finished up replacing the water pump on my '07 G35 Journey. Filled the system with coolant and started her up. Started first try and all sounds normal. While I was topping it off as it let out air the idle wasn't coming down. It's staying between 1400 - 1700 rpm. Temp came up to middle pretty quickly, but this has been the case with this car since I bought it 4 years ago. I'm thinking an air leak, but so far can't find any. I'm pretty sure all hoses are connected, but it's certainly possible I missed one. Any other ideas for me to look for?

Also, the coolant started coming out of the fill neck. I believe this is due to the t-stat not being opened yet (I didn't give it that much time).

Tom


tjrob2000
Posts: 56
Joined: Sat Jun 07, 2014 5:42 pm
Car: 2007 G35 sedan (journey)

Re: Water pump replacement done, now high idle?

Postby tjrob2000 » Sat Aug 25, 2018 3:34 pm

Sorry for the late follow-up here. This was solved by properly doing the idle air relearn.

User avatar
audtatious
Moderator
Posts: 36838
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: Water pump replacement done, now high idle?

Postby audtatious » Fri Oct 19, 2018 12:02 pm

Thanks for the update, something we don't get often with slow posting on forums nowadays.


Return to “G35 and G37 Engine, Drivetrain & Tuning”