Transmission Problems due to Neutral Safety Switch on J30

General discussion forum for J30 and M30 owners!
alex61089
Posts: 240
Joined: Fri Feb 20, 2009 8:06 am
Car: 1993 Infiniti J30t(crashed) 2006 Altima SL Special Edition 31K.
Contact:

Neutral Safety Switch on J30

Postby alex61089 » Tue Sep 22, 2009 7:29 am

So this is my post to inform everyone who knows of my problem and those who don't that. Replacing the Inhibitor switch (otherwise known as the Neutral Safety Switch) has fixed my transmission hunting problem.

This part doesn't normally cause such issues but we have seen with 2 members on here; including me; that it does. I've killed about 5 birds with this stone (stone being the part, birds being problems lol) And PETA fans, don't attack me.Anyway, They Included

1.Transmission hunting between 3rd and overdrive, not locking up2. Reverse Lights Not working3. Odd Shifting4. Delayed throttle response5. Transmission self diagnostic not working.

Putting in this part solved all of these problems. so if your diagnostic isnt working for your tranny, I highly suggest looking into this part, or maybe even with all these other problems.Now....

You can buy the part from IOS for 127.00 and some change, but then you have shipping. So you're looking at 140.00If you don't want to wait for it to be shipped and of course pay more then you can buy your Neutral Safety Switch from AUTOZONEThey sold it to me for 109.00 plus tax so it was about 117.00. Now read carefully because this next part is important.DO NOT and I MEAN DO NOT take this part to be installed by pepboys, strauss auto, ect. blah. Take it to a Transmission mechanic who YOU TRUST. I took mine to pepboys and strauss auto. both wanted around 90.00s for labor but when the car went on the lift decided, "they couldn't do it" I then took it to my Transmission mechanic who put it in less than 45minutes. and charged me 63.00 for it. This is not a labor intensive part, therefore do not subject yourself to paying 300.00 for labor.

i tried to put it on myself (put the car up on ramps) but much to my fear of the car collapsing on me and and lack of space to move and the inability to find the part it was much easier to pay for it. So umm yeah. Thanks ROT for making that post and discovering it the was Inhibitor switch in the first place and helping me solve a 7 month problem i've had.

EDIT:: And of course thank you to all nico club members who contributed to help me


User avatar
driverdriver
Posts: 3651
Joined: Fri Aug 01, 2003 10:36 am
Car: NICO's longtime resident Canuck!!!
Contact:

Postby driverdriver » Wed Sep 23, 2009 10:37 am

I think this post is important enough to be its own "stuck" item.

Thanks Alex!!!

alex61089
Posts: 240
Joined: Fri Feb 20, 2009 8:06 am
Car: 1993 Infiniti J30t(crashed) 2006 Altima SL Special Edition 31K.
Contact:

Re: (driverdriver)

Postby alex61089 » Wed Sep 23, 2009 10:54 am

Thanks I just hope this helps someone else who may be having the same problems so they won't be clueless as we once were

User avatar
yodawill2000
Posts: 3888
Joined: Thu Mar 24, 2005 4:10 pm
Car: 94 Infiniti J30
Location: Grand Prairie TEXAS

Postby yodawill2000 » Wed Sep 23, 2009 11:34 am

Especially when many were thinking the Transmission was shot I will be adding that switch into my spare parts pile soon !!!

User avatar
mels95j30
Posts: 69
Joined: Sun Oct 26, 2008 7:37 pm
Car: 90 nissan 240sx/silvia
Contact:

Re: (yodawill2000)

Postby mels95j30 » Tue Oct 06, 2009 8:42 pm

Iv noticed that my j is shifting alil to fast through the gears !? Do you think that's my problem ?should I gohead n buy that switch ?

alex61089
Posts: 240
Joined: Fri Feb 20, 2009 8:06 am
Car: 1993 Infiniti J30t(crashed) 2006 Altima SL Special Edition 31K.
Contact:

Re: (mels95j30)

Postby alex61089 » Thu Oct 08, 2009 10:46 am

could be the adjustment of your throttle position switch or possibly even a revolution sensor...use the transmission diagnostic to determine if there are any problemsHowever if i remember correctly These cars are known for having poor gear shift ratios.

User avatar
pktj21
Posts: 40
Joined: Tue Mar 11, 2008 2:51 pm
Car: 1990 nissan 240sx ka24e.3" jdm exhaust, strut bars F/R, home made intake,17" icw'

Re: Neutral Safety Switch on J30 (alex61089)

Postby pktj21 » Fri Oct 16, 2009 6:15 pm

is this the same auto trans thats in a 90 nissan 240sx the RE4R01A because i have been having the same issues

kcmoJ30t
Posts: 4
Joined: Mon Nov 02, 2009 8:36 am
Car: 1995 Infiniti J30t

Re: Neutral Safety Switch on J30 (alex61089)

Postby kcmoJ30t » Mon Nov 02, 2009 8:55 am

I recently had a minor wreck to my 1995 J30t (85,000 miles) that damaged my front right headlight, bumper, and quater panel. The car is still driveable, but on my way to get it looked at the transmission wasn't shifting into OD on the highway. It would shift fine from 1st thru 3rd. I also noticed that my gear shifter wasnt working when I tried manaully downshifting into 2nd or 1st while driving around 20 mph. My car has never had any kind of transmission problems before I got into a wreck. Does anyone think the wreck had anything to do with my transmission acting up or is it just coincidence? I was hoping the problem would be electrical or something minor. Thanks in advance for any help or suggestions.

toader2012
Posts: 2
Joined: Wed Jul 11, 2012 6:33 pm
Car: Infiniti J30 1995

Re: Transmission Problems due to Neutral Safety Switch on J3

Postby toader2012 » Wed Jul 11, 2012 6:49 pm

Hello. New to the site. I know this post is old but having issue that may relate. As I begin to drive my j30 the shifting is a little rough.as it warms up, it smoothes out. As I continue to drive it runs fine. But when the car is under more stress; such as stop and go. Rush hour. Or getting off the freeway the fans begin to turn on with or without ac. So there is reason to all this above. Anyway; the car seems like its hotter then norm and when I come to a complete stop all is well fans on the motor. An

Thanks ad car is running great. As I begin to accelerate there is a huge delay that wasn't there before. At times it feels like a 5 second delay and then when it nears 15-20 mph its fine.

Conditions @ most times: hot as hell(Arizona). Temps over 90 degrees outside. Humidity about 10% or less. Car running mid temp. According to gauge. Oil changed 1000 mil
es ago. But was occurring then too.
Considering parts: trans cooler kit with electric fan. Bigger radiator if possible. Injector Clearner. Neutral safty switch. And then if I can make it last enough planning on transmission rebuild. Sorry for grammer and everything else. Using my phone. Any help would be great.

toader2012
Posts: 2
Joined: Wed Jul 11, 2012 6:33 pm
Car: Infiniti J30 1995

Re: Transmission Problems due to Neutral Safety Switch on J3

Postby toader2012 » Wed Jul 11, 2012 6:51 pm

And car is running great. I don't know how that got screwed up.


Return to “J30 Forum / M30 Forum”