Transmission issue

Forum for Infiniti M35 and M45, and Nissan Fuga owners.
JJM158
Posts: 53
Joined: Mon Sep 02, 2019 7:25 pm
Car: 2007 Infiniti M35 S

Transmission issue

Postby JJM158 » Mon May 03, 2021 11:51 am

Last week I noticed my transmission felt stuck in 4th gear when accelerating as it was more difficult to get going. This is not manual mode but in Drive mode it feels like it starts in 4th and wont up or downshift. My AT check light came on but scanned a P1815 and was a previous stored code, and didn't think that was my issue. My SES light came on while on my way to the dealer,I had my car looked at and they read a P7044 code,they are thinking a failing valve body. I am currently looking to contact a tranny shop to get their opinon, I think it is some sensor within the trans. Another note my transmission fluid is not low however it is brown and probably needs changing.


User avatar
Ilya
Moderator
Posts: 9395
Joined: Fri Apr 23, 2010 11:20 pm
Car: 2011 M56x but I spend a lot of time on my 2015 Kawasaki Vulcan S. Former owner of a 2007 M35x. Also take care of my wife's 2016 QX60.
Location: Tampa, FL
Contact:

Re: Transmission issue

Postby Ilya » Mon May 03, 2021 12:12 pm

Depending on the mileage of the fluid it *may* due more harm than good based on what the general rule of thumb in the automotive world is. However, if you've been servicing it regularly, it may be worth doing.

User avatar
VStar650CL
Posts: 1586
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: Transmission issue

Postby VStar650CL » Mon May 03, 2021 12:34 pm

JJM158 wrote:
Mon May 03, 2021 11:51 am
Another note my transmission fluid is not low however it is brown and probably needs changing.
There's brown and then there's muddy. If it's not transparent anymore, chances are a change will make the misbehavior worse.

JJM158
Posts: 53
Joined: Mon Sep 02, 2019 7:25 pm
Car: 2007 Infiniti M35 S

Re: Transmission issue

Postby JJM158 » Mon May 03, 2021 1:06 pm

It is still transparent, just brown.

JJM158
Posts: 53
Joined: Mon Sep 02, 2019 7:25 pm
Car: 2007 Infiniti M35 S

Re: Transmission issue

Postby JJM158 » Mon May 03, 2021 2:51 pm

JJM158 wrote:
Mon May 03, 2021 1:06 pm
It is still transparent, just brown.
But besides fluid what else could be issue


Return to “Infiniti M35 and M45 Forum”