Strange oxygen sensor behavior

Discussion of Infiniti's amazing (and underrated) sport-luxury crossovers, the EX35 and EX37. For 2014, the EX series will be renamed QX50, in line with Ininfiit's new naming conventions.
sparksatwindsor
Posts: 2
Joined: Sat Jan 02, 2021 4:03 pm
Car: ???

Strange oxygen sensor behavior

Postby sparksatwindsor » Sat Jan 09, 2021 11:15 am

I have a 2008 Infiniti EX 35. Recently the service engine light went on and I saw codes P0051 (Heater Control Circuit Low Bank 2 Sensor 1), P0150 (O2 Sensor Circuit (Bank 2 Sensor 1). After doing some research I decided to replace the Bank 2 Sensor 1 oxygen sensor. I replaced the sensor with an NTK 25685 from Rock Auto.

After replacing the sensor the Short Term Fuel Trim for Bank 2 is basically pegged at 25 with the exception of dropping to 0 for a few seconds every minute or so. This happens if the engine is at idle or at most any RPM.

I am now getting an error code of P0174 System too Lean (Bank 2).

I bought the NTK sensor from Rock Auto because, in my research, I saw people recommending to buy the OEM sensor because the non-OEM sensors can cause problems. It seems like the new sensor is not working correctly. I considered trying to swap with the bank one sensor but it is very difficult to get at.

Any thoughts on what I might do to figure out what is going on would be very much appreciated


User avatar
VStar650CL
Posts: 1399
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Altima 2.5 SL, 2004 Altima 2.5 S

Re: Strange oxygen sensor behavior

Postby VStar650CL » Sat Jan 09, 2021 11:34 am

Sounds very much like it's just a bum sensor. It can't be flatlining or you'd be getting a reprise of the P0150. Has to be a performance issue with the sensor voltages.

sparksatwindsor
Posts: 2
Joined: Sat Jan 02, 2021 4:03 pm
Car: ???

Re: Strange oxygen sensor behavior

Postby sparksatwindsor » Sat Jan 09, 2021 4:53 pm

Thanks for the feedback. I wonder if Rockauto will exchange it for me. I'll give it a try.


Return to “Infiniti EX35 / EX37 and QX50 Forum”