Speedometer running backwards

ONLY for ADVANCED technical discussion about the 240sx!
Ehbahhowzit
Posts: 2
Joined: Thu Jul 12, 2018 7:31 pm
Car: 1991 240sx

Speedometer running backwards

Postby Ehbahhowzit » Fri Jul 13, 2018 5:20 pm

Hello all,
So I've been looking around for any information on this topic and found some old forums, BUT the original posters never posted what it was that actually fixed it for them. Hoping I can find some people that have had this problem and can tell me what they did to fix it.

My speedometer lays on the far right side way past 115. It used to never move but would sometimes jump back to life and work normally, so I know it works, albeit very rarely.

The last time I took it to the mechanic, he took the speed sensor out and cleaned it, and now it works... sort of. It will now rise up from the right side at around 40-50 mph and settle at around the 90 mark. If I let off the gas, it'll immediately drop back down to the far right. It's not reading correctly, but at least it moves every time now.

My question is: how do I get this thing to work properly?!

I'm hoping the members of NicoClub can help me because this seems to be the most mature and actually helpful 240 forum by far.


User avatar
Hijacker
Moderator
Posts: 15734
Joined: Wed Aug 13, 2003 4:57 am
Car: '92 240sx Convertible
'11 Pathfinder
Location: Fredericksburg, VA

Re: Speedometer running backwards

Postby Hijacker » Sat Jul 14, 2018 8:37 am

Never heard of this happening before. I've heard of people pulling the needles to do work on the gauge faces and then screwing up reinstalling the needle. If it were me, I'd find a new speedo and swap it in.

Cone Killer
Posts: 32
Joined: Thu Feb 23, 2012 10:18 pm
Car: 1991 240sx
Location: St. Petersburg, FL

Re: Speedometer running backwards

Postby Cone Killer » Sat Jul 28, 2018 1:01 pm

Speedos on the early S13 were very prone to crapping out. Yours is doing exactly what mine did a few years ago, I wrote up a thread a while back on it, heres the link, hope it helps !

topic556878.html


Return to “240SX Technical Forum”

cron