S13 fuel pump not priming

ONLY for ADVANCED technical discussion about the 240sx!
MarvZeb
Posts: 2
Joined: Sun Jan 03, 2021 4:23 pm
Car: 1992 Nissan 240SX KA24DET

S13 fuel pump not priming

Postby MarvZeb » Sun Jan 03, 2021 4:37 pm

Car won't start since car isn't getting fuel, I know the fuel pump isn't getting power from the plug that connects to it and the fuse is good the wires in the fenders are still intact only thing that remains is the relay which I don't know how to check if its good or not and the ecu which I'm hoping it's not


User avatar
NukeKS14
Posts: 189
Joined: Wed Apr 10, 2019 2:50 pm
Car: 1995 240SX SE - KA24DE-T
2014 Camaro SS 1LE

Re: S13 fuel pump not priming

Postby NukeKS14 » Sun Jan 03, 2021 7:19 pm

This site hosts factory service manuals. Go to the engine control section and there is a troubleshooting flow-chart to show you how to test the wiring and relay;

https://www.nicoclub.com/nissan-service-manuals

MarvZeb
Posts: 2
Joined: Sun Jan 03, 2021 4:23 pm
Car: 1992 Nissan 240SX KA24DET

Re: S13 fuel pump not priming

Postby MarvZeb » Mon Jan 04, 2021 5:53 pm

Today I switched out the relay and still no luck and another thing to note is that the plug in the hatch that connects to pump only one of those holes (don't remember the name) slighty lights up when I use a test light, really trying to get this thing started soon so any help is much appreciated

User avatar
NukeKS14
Posts: 189
Joined: Wed Apr 10, 2019 2:50 pm
Car: 1995 240SX SE - KA24DE-T
2014 Camaro SS 1LE

Re: S13 fuel pump not priming

Postby NukeKS14 » Thu Jan 07, 2021 10:20 am

Instead of shotgunning parts you could navigate to the FSM there and it will show you what wiring and components to test. Really.


Return to “240SX Technical Forum”