Reoccurring power loss?

ONLY for ADVANCED technical discussion about the 240sx!
Sketchy240sx
Posts: 5
Joined: Thu Jun 25, 2020 7:29 am
Car: 1993 240sx

Reoccurring power loss?

Postby Sketchy240sx » Tue Jun 30, 2020 5:47 pm

Back on here with another issue..so while driving around for an hour I was in a stop trying to turn left when suddenly in first gear the car was hesitating and would barely even move an inch, bogging back and forth feeling like there was no power whatsoever. I then shut my car and it started right back up with no problem and continued to drive. 20 minutes later the issues came back, this time I put my foot to the max point on the accelerator and it made no difference. Just bogged back and forth with barely any movement and everyone honking, causing traffic. Turning off my car and starting it again seems to get rid of it temporarily but it would soon come back sooner than before. I noticed during a stop before putting the car into first gear the idle would drop severely and the engine sounds like it was sputtering. Keep in mind I was on a full tank of gas so it left me even more confused since my fuel gauge is a little off. Anyone had the same issues?
I even think at one point during a stop the rpms just kept dropping until it died.
Could this be a bad fuel pump, fuel injectors?


User avatar
NukeKS14
Posts: 143
Joined: Wed Apr 10, 2019 2:50 pm
Car: 1995 240SX SE - KA24DE-T
2014 Camaro SS 1LE

Re: Reoccurring power loss?

Postby NukeKS14 » Thu Jul 02, 2020 5:38 pm

look up FSM for your car. Pull codes from ECU. follow FSM flow chart to troubleshoot. If that does not yield success then post up what you found/did.

https://www.nicoclub.com/nissan-service-manuals


Return to “240SX Technical Forum”