Rb20det cranks but no start unless forced too

Discuss the RB20, RB25 and RB26 series engines.
Bucketcoupe
Posts: 2
Joined: Fri Aug 20, 2021 8:15 pm
Car: '89 Nissan 240SX coupe

Rb20det cranks but no start unless forced too

Postby Bucketcoupe » Sun Aug 22, 2021 5:15 pm

Hello, new to this form and not 100% on how to use it quite yet .. I’m sure there’s a form on this already but ima make one because no matter how hard I search can’t seem to find an answer so maybe this form will help

I have a 89 s13coupe that I swapped a Rb20det from a 89 skyline gtst . Motors all stock minus a different bov and FMIC. Bought a wiring specialist harness fur plug n play action . Car cranks and will start up if I spray brake clean in the throttle body . Once it’s started it will stay running but will stutter when I open the throttle up at first then it clears up and can rev it however high I want . It will always do it ..

Fuel pump is a aem 320lph

Fuel pump primes and car is getting fuel .

What do you guys think my issue is ? I have to force to car to fire up every time .


Bucketcoupe
Posts: 2
Joined: Fri Aug 20, 2021 8:15 pm
Car: '89 Nissan 240SX coupe

Re: Rb20det cranks but no start unless forced too

Postby Bucketcoupe » Sun Aug 22, 2021 5:17 pm

Bucketcoupe wrote:
Sun Aug 22, 2021 5:15 pm
Hello, new to this form and not 100% on how to use it quite yet .. I’m sure there’s a form on this already but ima make one because no matter how hard I search can’t seem to find an answer so maybe this form will help

I have a 89 s13coupe that I swapped a Rb20det from a 89 skyline gtst . Motors all stock minus a different bov and FMIC. Bought a wiring specialist harness fur plug n play action . Car cranks and will start up if I spray brake clean in the throttle body . Once it’s started it will stay running but will stutter when I open the throttle up at first then it clears up and can rev it however high I want . It will always do it ..

Fuel pump is a aem 320lph

Fuel pump primes and car is getting fuel .

What do you guys think my issue is ? I have to force to car to fire up every time .


Return to “RB20DET / RB25DET / RB26DETT Forum”