Rb20 swapped s13 HELP PLEASE

A forum for owners and fans of the legendary Nissan Skyline and Nissan GTR.
Zooeydeschanel
Posts: 2
Joined: Thu Aug 25, 2016 5:28 pm
Car: 1994 240sx rb20 swapped

Rb20 swapped s13 HELP PLEASE

Postby Zooeydeschanel » Thu Aug 25, 2016 5:40 pm

Pleaseeee help me!!
So my car stopped working one day and after two weeks of stress I got a used CAS and it worked! And then it started to misfire but then I fixed it Because of a loose wire apparently?? but then my car started to act up again 2 days later and it died and would sometimes turn over but always would die after a second. It would only start if you constantly sprayed carburetor fluid into the MAF. The second you stop spraying it dies. I made sure the fuel pump was good(makes a whining noise but tested it and it still works) My fuel pressure is good, my injectors are good and I just cleaned them out and I got new spark plugs so I'm at a total loss because I also made sure my CAS was working and my igniter is working as well and my ECU! I put the CAS, igniter, and ecu on my friends rb20 and his ran good!
I have no clue what's happening with it PLEASE HELP


User avatar
lexcrob
Posts: 559
Joined: Mon Sep 22, 2008 7:38 pm
Car: I get a different ride faster than I could update this.
Location: Clarksville, TN
Contact:

Re: Rb20 swapped s13 HELP PLEASE

Postby lexcrob » Tue Aug 30, 2016 1:34 am

Could be poor grounding.
Possibly a very large boost or vacuum leak.
Bad gas.
Sometimes just disconnecting all the engine connectors and tweaking the pins solves that kind of thing.

You could get a noid light thing and put it in the fuel injector socket and make sure its blinking. Or just put a stethescope ear thingy on them listen for the click while cranking.

You can just take off the CAS and spin it and the injectors should be clicking away.

Beyond that yank the harness and strip off the tape and look it over is really all you can do. Grounds is the problem alot on the swapped stuff.

Zooeydeschanel
Posts: 2
Joined: Thu Aug 25, 2016 5:28 pm
Car: 1994 240sx rb20 swapped

Re: Rb20 swapped s13 HELP PLEASE

Postby Zooeydeschanel » Thu Sep 01, 2016 8:07 pm

My injectors don't click but maybe once in a blue moon when I spin the CAS. And when I tried to use that stethoscope I only heard it once!
But I'll try the other things too. Hopi. I don't have to buy a new harness


Return to “GTR Forum / Skyline Forum”