RB 25DET will not hold idle after warm-up and rev

Discuss the RB20, RB25 and RB26 series engines.
[email protected]
Posts: 12
Joined: Mon Dec 30, 2019 5:28 am
Car: 1994 Nissan 240sx RB 25 DET swap

RB 25DET will not hold idle after warm-up and rev

Postby [email protected] » Fri Sep 25, 2020 5:06 am

Hope someone can help me with this frustrating situation. My 240 SX with an RB 25DET swap starts perfectly idols nice and smooth from cold start to warm up but then when you rev it and release the gas pedal it will not re-catch the idle and it sputters and dies. I adjusted the throttle position sensor to read .48 V, replaced the AAC .
When I turn the AAC screw in and out it raises and lowers the idle as it should, but again, after fully warmed, when you give it a rev and release it sputters and die. When I start it back up it just chugs like it is starving , and I hear a "click click" eminating from what looks like a two inch long , large diameter hex bolt attatched to the head , towards the front of the car . It has a two wire connector attatched to it's end and that is where the clicking is coming from. I put an ohm meter on the throttle position sensor and at throttle plate closed I'm reading 1420 ohms and then when I open the throttle fully I am reading 8K ohms. Could that be the issue ?
I sure hope this sounds familiar to somebody have not been able to drive the car for sometime now thank you so much everyone.


Yellow4g63
Posts: 3717
Joined: Mon Jan 20, 2003 6:07 pm
Car: 95 RB20 240, 91 NX2000 VE power, 95 Stock 240sx
Contact:

Re: RB 25DET will not hold idle after warm-up and rev

Postby Yellow4g63 » Tue Oct 06, 2020 11:39 pm

Have you checked the ecu for any codes yet? have you tried unplugging the maf sensor and see if it will hold the idle?


Return to “RB20DET / RB25DET / RB26DETT Forum”