Problem with License Plate Lights [SOLVED - LED bulb polarity]

Forum for Infiniti M35 and M45, and Nissan Fuga owners.
bejackier
Posts: 4
Joined: Sun Apr 14, 2019 7:52 pm
Car: 2006 infiniti M35

Problem with License Plate Lights [SOLVED - LED bulb polarity]

Postby bejackier » Mon Apr 15, 2019 10:52 am

Hi, I have a 2006 M35. The license plate lights are not functioning. I have changed out the bulbs and still no-go. All of the other lights throughout the vehicle work. I can't find any fuses specifically only for the license plate lights. Any suggestions on where else to look would be appreciated. Thanks.


EdBwoy
Moderator
Posts: 3141
Joined: Tue Dec 25, 2012 12:47 am
Location: St. Louis Metro East - IL
Contact:

Re: Problem with License Plate Lights

Postby EdBwoy » Mon Apr 15, 2019 10:39 pm

Remove the trunk lid trim and check underneath to make sure the bulb receptacles are connected to the wiring harness.

bejackier
Posts: 4
Joined: Sun Apr 14, 2019 7:52 pm
Car: 2006 infiniti M35

Re: Problem with License Plate Lights

Postby bejackier » Tue Apr 16, 2019 8:48 am

I did that when I replaced the bulbs. After I replaced the bulbs, I still had no functioning light.

User avatar
pedsemdoc
Posts: 1014
Joined: Mon Jun 07, 2010 1:45 pm
Car: 2013 M37 Sport - SOLD, Premium/Tech/Sport Journey
Carbon fiber engine cover
GT Spec front tower strut bar
R2C Intakes
Oil catch cans
Custom Start button LEDs
Location: Southlake, Texas

Re: Problem with License Plate Lights

Postby pedsemdoc » Tue Apr 16, 2019 4:38 pm

Since all your other lights work - could still be a fuse problem, would check all of them (someone posted in the Armada forums that they had the same problem and he tought all his fuses were fine until he looked individually at each one and found one burned out.)
You should also take a good luck at your connectors, I had one rear turn signal go out and the bulb was fine, fuses were fine - then I looked at the connector and one of the wires has corroded so badly that it couldn't make a connection anymore to the bulb wires. I peeled back the rubber boot of the connector and soldered a new wire in place - Bob's yer uncle/good as new!

Could also be an issue with the connectors/electrical relays, see image below (could be body sub harnesses 151 or 104):
I'd get a voltmeter and check to see if you have continuity at those pins.

Image

Good luck - let us know how it all pans out.

Craig

EdBwoy
Moderator
Posts: 3141
Joined: Tue Dec 25, 2012 12:47 am
Location: St. Louis Metro East - IL
Contact:

Re: Problem with License Plate Lights

Postby EdBwoy » Tue Apr 16, 2019 9:05 pm

As you troubleshoot, this info might help you.

The license plate lights aren't on a separate circuit. The fuses that affect them would also affect the parking lights and tail lamps.

bejackier
Posts: 4
Joined: Sun Apr 14, 2019 7:52 pm
Car: 2006 infiniti M35

Re: Problem with License Plate Lights

Postby bejackier » Tue Apr 16, 2019 9:08 pm

Any idea then what might be the problem?

Larz
Moderator
Posts: 2801
Joined: Thu Feb 21, 2013 8:55 pm
Car: 2009 M35 RWD
Location: Ft Lauderdale, Florida
Contact:

Re: Problem with License Plate Lights

Postby Larz » Thu Apr 18, 2019 10:35 pm

Have you checked everything with the voltmeter? It has to be a connection, a fuse, or the actual bulb socket itself. Report back after you have checked those things.
Did both bulbs stop working nat the same tine? Are you upgrading to LED or replacing with the same bulbs?

Larz
Moderator
Posts: 2801
Joined: Thu Feb 21, 2013 8:55 pm
Car: 2009 M35 RWD
Location: Ft Lauderdale, Florida
Contact:

Re: Problem with License Plate Lights

Postby Larz » Thu Apr 18, 2019 10:36 pm

Have you checked everything with the voltmeter? It has to be a connection, a fuse, or the actual bulb socket itself. Report back after you have checked those things.
Did both bulbs stop working at the same time? Are you upgrading to LED or replacing with the same bulbs?

User avatar
Mjkkb2
Posts: 666
Joined: Mon Oct 21, 2013 11:37 am
Car: 2018 QX60 AWD, 2011 M37S, 2011 Quest, 2001 I30t(sold)
Location: Richmond VA

Re: Problem with License Plate Lights

Postby Mjkkb2 » Fri Apr 19, 2019 6:33 am

I would try another set of (different) bulbs. While replacing mine with LED, the wouldn't light up. Turned out they were defective (a new set). Additionally LED bulbs may not work if inserted the wrong way. Try rotating them 180 deg.

Ignore this post if you're not swapping to LEDs.

good luck.

bejackier
Posts: 4
Joined: Sun Apr 14, 2019 7:52 pm
Car: 2006 infiniti M35

Re: Problem with License Plate Lights

Postby bejackier » Fri Apr 19, 2019 11:46 am

THANKS to all. The last suggestion worked!! I reversed the LED bulbs and the lights came on. Very happy...


Return to “Infiniti M35 and M45 Forum”