03 G35 Pink 40/30/30 amp

A general discussion forum for G35 and G37 owners and a great place to introduce yourself to the NICOclub G-Series Forums!
ncook523
Posts: 1
Joined: Sun Aug 02, 2020 8:56 am
Car: 2003 Infiniti G35

03 G35 Pink 40/30/30 amp

Postby ncook523 » Sun Aug 02, 2020 5:07 pm

Hello everyone, the AMP in my car is blowing. the 40 fuse in the amp is blowing, i recently just installed a new Starter in my car and everything was great. Then out of the blue this Damn fuse keeps popping. Where should i look and how.
any sort of insight would really mean alot to me
is there a false ground. UGH
on the box the 40A fuse says (IGN SW)


User avatar
telcoman
Posts: 5617
Joined: Sat Jul 08, 2006 11:30 am
Car: 2016 Q70 Bye 2012 G37S 6 MT w Nav 94444 mi bye 2006 Infiniti G35 Sedan 6 MT @171796mi. 2013 Altima 2.5SV
Location: Central NJ

Re: 03 G35 Pink 40/30/30 amp

Postby telcoman » Tue Aug 04, 2020 2:52 pm

I would suspect a defective starter? Have you removed the fiberboard shroud underneath your vehicle and perhaps water splashed into your wiring?
Remove the starter and have it bench tested.
It's a little late but it is always preferable to have your original OEM starter rebuilt at a qualified shop rather than purchase a cheap POS that is made in China
Good luck

Dbarry
Posts: 27
Joined: Wed Jan 24, 2018 1:23 am
Car: 240SX

Re: 03 G35 Pink 40/30/30 amp

Postby Dbarry » Thu Aug 13, 2020 5:54 pm

ncook523 wrote:
Sun Aug 02, 2020 5:07 pm
Hello everyone, the AMP in my car is blowing. the 40 fuse in the amp is blowing, i recently just installed a new Starter in my car and everything was great. Then out of the blue this Damn fuse keeps popping. Where should i look and how.
any sort of insight would really mean alot to me
is there a false ground. UGH
on the box the 40A fuse says (IGN SW)
Howdy! Have you figured out what causes the issue?


Return to “G35 and G37 General Discussions”