Nissan Versa 2009 Sedan - Need someone who car knowledge to help me problem solve an issue

The club for Nissan Maxima and Infiniti I30 / I35 owners, and the official home of Maxima Club of America!
RakeshJD
Posts: 9
Joined: Tue Nov 27, 2018 12:37 pm
Car: Nissan

Nissan Versa 2009 Sedan - Need someone who car knowledge to help me problem solve an issue

Postby RakeshJD » Fri Nov 30, 2018 11:01 pm

Hello guys,,,,
I have searched around the group, and saw older posts of the issue I am posting about, but given they were very old posts. I wanted to make a new one. Admins if you know of a better one please link it and I will move to that post, and this one can be deleted if need be.

My BF has a Nissan Versa 2009 Sedan, and he isn't a car guy, and knows nadda of cars. I have the basic knowledge to get me by, but his car is having an issue I'm trying to figure out to fix but limited at option due to money.

I wanted to know if anyone has encountered this issue and have any wisdom to help me.

So his car won't start, but the battery is fine, the starter is fine, and all connections look good. When I try to turn on the car you can hear the clicks but its very fast (like a semi-automatic gun but not as fast but close.)

I am thinking its a fuse or something in the connection line via Starter > Battery > to Engin has a problem. :/ Halp?


User avatar
Rogue One
Moderator
Posts: 8385
Joined: Tue Jun 14, 2011 10:15 pm
Car: 2011 Nissan Rogue SL
2012 Nissan Rogue SL
2012 Honda CR-V LX
Location: Florida, USA

Re: Nissan Versa 2009 Sedan - Need someone who car knowledge to help me problem solve an issue

Postby Rogue One » Sun Dec 02, 2018 8:56 am

OP is a spammer and has been dealt with accordingly.


Return to “Maxima Forum & I30 / I35 Forum”