New radio, but now my gauge cluster lights dont work...

A forum for owners and fans of the legendary Nissan Skyline and Nissan GTR.
TheJDMguy101
Posts: 2
Joined: Sun Dec 03, 2017 11:05 am
Car: -1990 S13 (rb25 swapped)
-1991 S13 (daily)
-2010 F-150 (parts truck)

New radio, but now my gauge cluster lights dont work...

Postby TheJDMguy101 » Sat Mar 23, 2019 10:27 pm

So the story goes:

I took my r32, that I just imported over from japan, into best buy to get a new head unit and speakers. The guy installed my new head unit, with no problems. I didnt find out til that night that the running lights werent working. However the HICAS light, e-brake light, and all the warning lights worked. The speedometer, tach, center gauges (boost, battery, and oil temp) were NOT working also my taillights as well, my taillights work when pressing the brake. I've checked the fuses, tried to comprehend the wiring schematics however I cant find out what's wrong, PLEASE SOMEONE HELP ME!!!


04pathse
Posts: 680
Joined: Sun May 02, 2010 2:55 pm
Car: 2004 Nissan Pathfinder SE
2008.5 Mazda Mazdaspeed 3

Re: New radio, but now my gauge cluster lights dont work...

Postby 04pathse » Sun Mar 24, 2019 11:35 pm

TheJDMguy101 wrote:
Sat Mar 23, 2019 10:27 pm
So the story goes:

I took my r32, that I just imported over from japan, into best buy to get a new head unit and speakers. The guy installed my new head unit, with no problems. I didnt find out til that night that the running lights werent working. However the HICAS light, e-brake light, and all the warning lights worked. The speedometer, tach, center gauges (boost, battery, and oil temp) were NOT working also my taillights as well, my taillights work when pressing the brake. I've checked the fuses, tried to comprehend the wiring schematics however I cant find out what's wrong, PLEASE SOMEONE HELP ME!!!
If everything was working fine before the install, I would take it back to BEST BUY and have them fix it

User avatar
mybemore
Posts: 5
Joined: Fri Mar 29, 2019 9:23 pm
Car: 2018 Nissan Pathfinder

Re: New radio, but now my gauge cluster lights dont work...

Postby mybemore » Sun Apr 28, 2019 8:38 pm

Have you solved your problem with cluster lights?

User avatar
zerepdivad
Posts: 2007
Joined: Thu Nov 24, 2005 5:39 pm
Car: '90 240sx . '02 Lexus IS300
Location: Elkhorn, WI

Re: New radio, but now my gauge cluster lights dont work...

Postby zerepdivad » Tue May 07, 2019 9:32 am

They blew the illumination fuse. Understandable if the wiring harness was already butchered with bare wires and they got moved. They also might have grounded it to the illumination wire. Either way, they have a lifetime warranty on workmanship so just go back and they can fix it. or just check your fuses.


Return to “GTR Forum / Skyline Forum”