new guy here I really need help asap

Discussion forum for the venerable 510, and its non-US counterparts, the Datsun 1600 and Bluebird.
Landojmz
Posts: 4
Joined: Sun Nov 09, 2014 1:48 pm
Car: 1979 Datsun 510

new guy here I really need help asap

Postby Landojmz » Sun Nov 09, 2014 1:59 pm

Guys im having trouble with my 79 510s brake lights the wont flash when I step on the brake please get to me fast.


User avatar
Rogue One
Moderator
Posts: 7392
Joined: Tue Jun 14, 2011 10:15 pm
Car: 2011 Nissan Rogue SL
2012 Nissan Rogue SL
2012 Honda CR-V LX
Location: Florida, USA

Re: new guy here I really need help asap

Postby Rogue One » Sun Nov 09, 2014 3:05 pm

Landojmz wrote:Guys im having trouble with my 79 510s brake lights the wont flash when I step on the brake please get to me fast.
Your question was rather vague, so it's nearly impossible to give an accurate answer.

You want to design your question effectively. Try to describe the problem or question as thoroughly as possible. Include all necessary details but no unnecessary ones.

Landojmz
Posts: 4
Joined: Sun Nov 09, 2014 1:48 pm
Car: 1979 Datsun 510

Re: new guy here I really need help asap

Postby Landojmz » Sun Nov 09, 2014 5:58 pm

I figured lol well I already pinned the problem its the brake light switch but I also have a problten with the back uup lamp its maybe the sensor that my best guess.

User avatar
AZhitman
Administrator
Posts: 69614
Joined: Mon Apr 29, 2002 2:04 am
Car: 72 240Z RB25, 63 Bluebird RHD, 63 NL320, 67 WRL411, 67 SPL311, 68 510 SR, 73 240Z, 77 620 SR20, 89 Pao, 98 S14, 12 Titan CC 4x4.
Location: Surprise, Arizona
Contact:

Re: new guy here I really need help asap

Postby AZhitman » Sun Nov 09, 2014 8:46 pm

The brake light switch is a common issue - that poor thing gets pretty abused, for a little plastic switch.

As for your reverse lights, the sensor is a good place to start - try jumping the two terminals to see if the lamps light up. If not, then you have a bulb or wiring issue.

Landojmz
Posts: 4
Joined: Sun Nov 09, 2014 1:48 pm
Car: 1979 Datsun 510

Re: new guy here I really need help asap

Postby Landojmz » Sun Nov 09, 2014 9:04 pm

I re grounded the back up light and changed the bulbs I will test current and and switch th wiring on that car is a mess I need to remove the useless sound system wires to start fromg ground up

User avatar
AZhitman
Administrator
Posts: 69614
Joined: Mon Apr 29, 2002 2:04 am
Car: 72 240Z RB25, 63 Bluebird RHD, 63 NL320, 67 WRL411, 67 SPL311, 68 510 SR, 73 240Z, 77 620 SR20, 89 Pao, 98 S14, 12 Titan CC 4x4.
Location: Surprise, Arizona
Contact:

Re: new guy here I really need help asap

Postby AZhitman » Mon Nov 10, 2014 11:40 pm

Yeah, it's hard to know what's problematic when the prior owners do some janky wiring.

Did you pull down the service manual and diagram from www.datsunservicemanual.com?


Return to “Datsun 510 / Bluebird”