Navigation issue

Forum for the unique Murano, and official home of Nissan Murano Club!
pmatawan
Posts: 3
Joined: Tue May 25, 2021 4:48 am
Car: 2020 Nissan Murano Platinum

Navigation issue

Postby pmatawan » Tue May 25, 2021 5:24 am

I have a 2020 Murano Platinum. The navigation system drops the house number and announces arrival when you reach the final street. I'm entering address manually, not through voice recognition. Doesn't happen every time, but often enough to make it useless without a smartphone to get you the last mile. Anyone else have this issue & is there a fix?


User avatar
VStar650CL
Posts: 2740
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: Navigation issue

Postby VStar650CL » Tue May 25, 2021 6:32 am

Try hooking up the WiFi and reloading the latest map data for your area, sometimes the maps get corrupted and it can cause all sorts of weird issues.

pmatawan
Posts: 3
Joined: Tue May 25, 2021 4:48 am
Car: 2020 Nissan Murano Platinum

Re: Navigation issue

Postby pmatawan » Tue Jun 08, 2021 10:59 am

Loaded new map version and still having same issue.
Here is what I discovered:
If I enter the City first, it drops the house number, even after house # and street have been manually entered.
If I enter the house number & street before the City, it works as it is supposed to.
Is it only supposed to work one way?

User avatar
VStar650CL
Posts: 2740
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: Navigation issue

Postby VStar650CL » Tue Jun 08, 2021 11:04 am

Yep, that's normal. Dunno why they programmed it that way, but a few of the other models also seem to do that.

pmatawan
Posts: 3
Joined: Tue May 25, 2021 4:48 am
Car: 2020 Nissan Murano Platinum

Re: Navigation issue

Postby pmatawan » Tue Jun 08, 2021 12:30 pm

Thanks for confirming that that the Nav is poorly programmed and not malfunctioning.
Had a 2009 Murano, never had an issue.

User avatar
VStar650CL
Posts: 2740
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: Navigation issue

Postby VStar650CL » Tue Jun 08, 2021 3:56 pm

Your '09 most likely had a Panasonic or Clarion, your '20 has a Bosch. I could bend your ear for an hour about how unhappy we all are with Bosch radios and navis.


Return to “Murano Forum”