my 2004 FX45 ISSUES

A forum for lovers of Infiniti's hot-rod crossover, the FX! In 2014, all FX models will be named Infiniti QX70, in line with Infiniti's new naming structure.
MIKEONE
Posts: 4
Joined: Mon Aug 25, 2014 8:53 am
Car: 2004 INFINITI FX45

my 2004 FX45 ISSUES

Postby MIKEONE » Mon Aug 25, 2014 11:03 am

Hello all! Im a newb here and i have just acquired an fx45 with a perplexing issue. when the engine warms up it stalls and throws out a code for a camshaft position sensor, i believe it was bank #1...so the previous owner had it in and replaced and it re-occured so they put the new sensor into bank#2 and then put the first sensor back , and the problem occured again. so i bought the car like this and am going about getting it on the road now. i talked to a Nissan dealer and he said to replace all the sensors with new ones, including the crank sensor, and then reset the computer and it should be fine...but it seems like a stab in the dark...my brother however, who is a mechanic fro GM says it could be a timing chain that is stretched...if anyone else has run into this what was your solution??

Thanks in advance :gotme


User avatar
ezb57e
Posts: 471
Joined: Sun Jun 29, 2014 9:02 pm

Re: my 2004 FX45 ISSUES

Postby ezb57e » Mon Aug 25, 2014 9:53 pm

Welcome.
Can't see how a timing chain would change much being cold or hot.
Is it full of oil and have good pressure at idle?
Temp relation could point to sensors.
It would be best to watch the CMPS signals during the incident.

User avatar
SX APPEAL
Posts: 1345
Joined: Tue Oct 05, 2004 10:26 am
Car: 06 G35 Coupe 6MT
95 Maxima SE 5MT
Location: Springfield, MO

Re: my 2004 FX45 ISSUES

Postby SX APPEAL » Thu Sep 11, 2014 2:55 pm

I'm in the parts department at an Infinti dealership and can tell you the cam/crank position issue is fairly common on the VQ V6 engines, and usually we do replace at least both of the cam sensors if not all three as a set. Timing chain issues are very uncommon with the V6's, as in almost never. The 5.6 V8's sometimes have timing chain problems but rarely the V6's. Hope this helps.

MIKEONE
Posts: 4
Joined: Mon Aug 25, 2014 8:53 am
Car: 2004 INFINITI FX45

Re: my 2004 FX45 ISSUES

Postby MIKEONE » Thu Sep 11, 2014 3:29 pm

its the V8 engine, not the V6, but its the 4.5 litre

User avatar
SX APPEAL
Posts: 1345
Joined: Tue Oct 05, 2004 10:26 am
Car: 06 G35 Coupe 6MT
95 Maxima SE 5MT
Location: Springfield, MO

Re: my 2004 FX45 ISSUES

Postby SX APPEAL » Thu Sep 11, 2014 3:37 pm

Guess if I had read the title a little closer I'd know that. Can't really weigh in too much on those then I guess because there aren't many of them out there and we rarely see them. In my experience though, like I said earlier, when we start replacing crank/cams sensors, we usually replace all of them.

MIKEONE
Posts: 4
Joined: Mon Aug 25, 2014 8:53 am
Car: 2004 INFINITI FX45

Re: my 2004 FX45 ISSUES

Postby MIKEONE » Thu Sep 11, 2014 3:41 pm

thanks, any idea what all three sensors is gonna set me back??

User avatar
SX APPEAL
Posts: 1345
Joined: Tue Oct 05, 2004 10:26 am
Car: 06 G35 Coupe 6MT
95 Maxima SE 5MT
Location: Springfield, MO

Re: my 2004 FX45 ISSUES

Postby SX APPEAL » Thu Sep 11, 2014 5:07 pm

Straight from the dealership, even if they cut you a deal they're still well over $100 a piece. However a lot of dealership parts departments (including my own) offer much better deals in their online stores. Many of these online stores are set up to look like they're not affiliated with a certain dealership, but trust me, they are. At the risk of plugging my own store without being a vendor on NICO I can't really say any more than that, but say you do a google search for infinti parts, several will probably come up, and they're all usually priced within a percent or two of each other.

MIKEONE
Posts: 4
Joined: Mon Aug 25, 2014 8:53 am
Car: 2004 INFINITI FX45

Re: my 2004 FX45 ISSUES

Postby MIKEONE » Fri Sep 12, 2014 8:21 am

Thanks!!!


Return to “Infiniti FX35 / FX45 / FX37 / FX50 / QX70 Forum”