93 Sentra Loss of Power when lights/AC are on

A great resource for Nissan Sentra, Infiniti G20, 200sx, Pulsar, NX1600, NX2000, Tsuru, Primera and Sunny owners.
dirtmcgird
Posts: 2
Joined: Wed Aug 15, 2018 6:42 pm
Car: 1993 Nissan Sentra GXE 1.6L

93 Sentra Loss of Power when lights/AC are on

Postby dirtmcgird » Wed Aug 15, 2018 6:56 pm

Hi guys, I have a 1993 Sentra GXE 1.6L, (173,000 mi.) Manual and recently I have been having a loss of power when the A/C or lights are on. I have replaced the battery last month, and the alternator is relatively new(less than 1 year old). I thought the issue was resolved, but when I was driving with the lights on it was fine until I hit the brakes and immediately the interior lights died down and the engine began to stall, when I downshifted there was no power at all and I had to remain in third gear until I could pull off. After stopping the car continued to run while in neutral and I could drive it with the lights off, but it would not start again. I checked the Alternator belt and it is not slipping. I think the power steering belt may be slipping since I can hear squealing under the hood, but I didn't think that would be something to rob power from the system. If anyone has an idea of what the issue may be, or where to start that would be a great help.


dirtmcgird
Posts: 2
Joined: Wed Aug 15, 2018 6:42 pm
Car: 1993 Nissan Sentra GXE 1.6L

Re: 93 Sentra Loss of Power when lights/AC are on

Postby dirtmcgird » Thu Aug 16, 2018 7:34 pm

UPDATE: I went through checks with the electrical systems, and when unplugging the fusible link that runs the internal systems, and the engine picked up. I'm still not sure if its the wire or the connector though. Any tips to test?


Return to “Sentra Forum / Infiniti G20 Forum / Pulsar / NX Forum”

cron