Leaning out under Load

Discuss topics related to the CA18DE and CA18DET series engines.
s13 Jrock
Posts: 60
Joined: Fri Oct 07, 2011 7:28 pm
Car: 90 s13 Hatch
CA18Det
Location: Bay Area,CA

Leaning out under Load

Postby s13 Jrock » Tue Apr 18, 2017 4:35 pm

As the title says, My CA is leading out under WOT and sometimes at idle.
Car ran legit in November drove it home from the track. its sat for a bit. battery eventually died. got new battery, car idles fine, sometimes the afrs will be good at idle (14.4-7ish), or eventually lean out "---" on AEM uego. if i let it build revs slowly the afrs stay pretty consistent but, if i jab the throttle, it breaks up an stutters.

mods:
oem rebuild
ARP rod bolts
s15 t28 (bought brand new)
z32 MAF
DW 550cc's
walbro 255
on SAFC2.

car has ran great and been extremely reliable since summer 2015, especially since the last big drive i made in it, it ran fine until parked and sat for about 3 months. (Reg. is Exp.)

so far i have:
Drained the old gas out and replaced it
tested fuel pump and it checks out
getting good fuel pressure.
had 550cc injectors cleaned and flow tested, they're good
replaced fuel filter
cleaned MAF
checked for vac leaks and found none (except were half moon seals are, but ive had those leak even when running well).
drop resistor is good
injectors are getting 12v
spark plugs replaced and gapped at .28 (running 15psi)
ECU codes checked. their are none. (55) tested on 2 ecus.

pretty stumped at this point. ive just about triple checked all the fuel related things.
wiring harness is also fairly new. really weird that just started acting up all of a sudden. really hope its somthing stupid and small.


User avatar
r34 gtr
Posts: 8909
Joined: Sun Dec 29, 2002 9:33 am
Car: 98 Frontier XE 4x4
95.5 Audi URS6 Avant 5spd
03 BMW 330i ZHP 6spd
89 240sx base CA18DET
Location: Creepin' in your crawl space
Contact:

Re: Leaning out under Load

Postby r34 gtr » Tue Apr 18, 2017 4:43 pm

Is the O2 sensor working correctly? Sounds like a bit of a stretch given the conditions under which it goes lean, but might be worth a shot.

Have any of the SAFC settings been reset? I know mine loved to act up when the battery had been out of the car for a while. Probably worth going through the SAFC to make sure everything is ok there too.

Sorry I can't be of more help. You have certainly tried most of the stuff I would suggest first.

s13 Jrock
Posts: 60
Joined: Fri Oct 07, 2011 7:28 pm
Car: 90 s13 Hatch
CA18Det
Location: Bay Area,CA

Re: Leaning out under Load

Postby s13 Jrock » Tue Apr 18, 2017 5:12 pm

i did unplug the o2 and didnt notice any change, its just as new as everything else. im wondering about the safc also. my friend who built the motor also tuned it for me so im not really sure about if some numbers changed and to what and he unfortunately lives a good distance away. but i may facetime him or something and see if he can help me out that route, i appreciate your reply though. sucks all the threads ive came across are either unfinished or there missing parts in there set up. :/

User avatar
r34 gtr
Posts: 8909
Joined: Sun Dec 29, 2002 9:33 am
Car: 98 Frontier XE 4x4
95.5 Audi URS6 Avant 5spd
03 BMW 330i ZHP 6spd
89 240sx base CA18DET
Location: Creepin' in your crawl space
Contact:

Re: Leaning out under Load

Postby r34 gtr » Thu Apr 20, 2017 5:20 pm

Yeah often when folks get a problem sorted out they don't make it back to update the thread. I am guilty of that myself.

I had your exact setup about 2004-ish. Wish I remembered some of the settings I had in it, but its been a hot minute for sure. Your best bet would be to invest in a wideband so you know what's going on. I think the Innovate LC1 runs about $150 and comes with a gauge.

s13 Jrock
Posts: 60
Joined: Fri Oct 07, 2011 7:28 pm
Car: 90 s13 Hatch
CA18Det
Location: Bay Area,CA

Re: Leaning out under Load

Postby s13 Jrock » Fri Apr 21, 2017 9:24 am

i have the aem wideband

s13 Jrock
Posts: 60
Joined: Fri Oct 07, 2011 7:28 pm
Car: 90 s13 Hatch
CA18Det
Location: Bay Area,CA

Re: Leaning out under Load

Postby s13 Jrock » Sat Apr 22, 2017 10:32 am

*UPDATE*

Z32 Maf was on its way out i guess. got another and we good!

Thanks for playing.

User avatar
r34 gtr
Posts: 8909
Joined: Sun Dec 29, 2002 9:33 am
Car: 98 Frontier XE 4x4
95.5 Audi URS6 Avant 5spd
03 BMW 330i ZHP 6spd
89 240sx base CA18DET
Location: Creepin' in your crawl space
Contact:

Re: Leaning out under Load

Postby r34 gtr » Tue Apr 25, 2017 11:43 am

s13 Jrock wrote:i have the aem wideband
Oh right. Obviously because the title of the thread is "leaning out under load."

Just when I dont think I could possibly get any stupider I do something like this and totALLY REDEEM MYSELF.

Glad you sorted out the problem!

User avatar
float_6969
Moderator
Posts: 19392
Joined: Mon Aug 26, 2002 1:55 pm
Car: CA18DET swapped 1995 Nissan 240sx (toy)
2003.5 Mazda Mazdaspeed Protege (lightly modded DD)
Location: Topeka, Kansas
Contact:

Re: Leaning out under Load

Postby float_6969 » Sun Apr 30, 2017 4:53 am

Thanks for updating the thread with the solution!!!


Return to “CA18DE / CA18DET Forum”