Lean bank 1

The G-Series Tuning Forum is the place to discuss G35/G37 performance modifications and mechanical repair.
zachggus
Posts: 11
Joined: Thu Apr 04, 2019 8:05 am
Car: 03 g35 sedan.

Lean bank 1

Postby zachggus » Sat Apr 06, 2019 4:56 pm

Just rebuilt my engine on my 03 G35. It is running lean on bank 1. Lt fuel trims at 129, short term is almost normal. I smoke tested it and couldn’t find a leak. Any help would be appreciated


zachggus
Posts: 11
Joined: Thu Apr 04, 2019 8:05 am
Car: 03 g35 sedan.

Re: Lean bank 1

Postby zachggus » Mon Apr 08, 2019 9:06 am

Update checked spark plugs on bank one and doesn’t looks like it has been running rich. I suspect a lack of fuel condition. I swapped injectors to see if it would move but not so far.

User avatar
JettaRed
Posts: 26
Joined: Wed May 21, 2008 4:25 am
Car: 2008 Infiniti G35x 2004 Audi TT 225Q 2004 Mercedes SL500
Contact:

Re: Lean bank 1

Postby JettaRed » Mon Apr 15, 2019 11:23 am

P0171 (Lean Bank 1) showed up about a month ago. I did everything:

-Replaced fuel injectors (had a set of factory injectors)
-Cleaned then replaced MAF sensors
-Replaced intake manifold gasket (found a mouse nest under the manifold)
-Replaced the Bank 1 A/F sensor (i.e., pre-cat O2 sensor)
-Smoke test - no leaks
-Disconnected the battery for about an hour

The LTFT is under 10%, but still elevated in comparison to Bank 2.

It usually takes a couple of days to throw the CEL, but I am scanning regularly for pending codes. Nothing yet.

Next step: replace the fuel damper assembly on the Bank 1 Fuel Rail if the LTFT keeps rising.

Since I am not running lean on Bank 2 (i.e., no P0174 and LTFT is close to 0%), I'm ruling out a bad fuel pump. However, if the Bank 1 fuel damper is clogged, that may be restricting fuel to those injectors.

zachggus
Posts: 11
Joined: Thu Apr 04, 2019 8:05 am
Car: 03 g35 sedan.

Re: Lean bank 1

Postby zachggus » Wed Apr 17, 2019 6:42 pm

Let me know. I’ve tried swapping injectors
Between banks. I also replaced af sensor bank 1. I am starting to get a miss on cyl 1 so I am suspecting a bad injector. Maybe the regulator is bad?

zachggus
Posts: 11
Joined: Thu Apr 04, 2019 8:05 am
Car: 03 g35 sedan.

Re: Lean bank 1

Postby zachggus » Wed Apr 24, 2019 8:48 pm

Checked fuel pressure it is good at 51 and steady under load. Reset fuel trim and it is just slightly high on bank 1 st is 106 but goes down to 98. Long term is perfect stays at 100. Bank 2 goes between 97 and 102 st both are within spec. Idk why but fuel trims are normal now. Maybe it needed a hard reset after I replaced o2 sensor. New problem intermittent misfire. Only in gear sitting still can put in park and it goes away. Doesn’t mis at all at any other rpm. No codes.


Return to “G35 and G37 Engine, Drivetrain & Tuning”