ka24de idles step on gas dies?!?!?!?

Information on the naturally-aspirated KA24E and KA24DE engines.
DRIFTN_SILVIA13
Posts: 28
Joined: Mon Sep 10, 2007 10:13 am

ka24de idles step on gas dies?!?!?!?

Postby DRIFTN_SILVIA13 » Wed Sep 12, 2007 2:40 pm

hows it going guys,i have a situation, i replaced my old kade with a 93 one. the motor is ok, sometimes it takes 2 or 3 times to start to make it crank over. it idles sometimes for a bit and sometimes for as long as i dont give it throttle. i have checked the coolant temp every time i disconnected while givining it throttle it stays on sometimes it doesnt. i think its a fuel related thing but not sure. would it be the fuel pump?

so please some one can help me out i have searched but no answer.


Toadstool
Posts: 72
Joined: Sat Dec 16, 2006 1:49 pm
Car: blown up, 240's

Re: ka24de idles step on gas dies?!?!?!? (DRIFTN_SILVIA13)

Postby Toadstool » Wed Sep 12, 2007 2:47 pm

Do you have fuel to the engine?check...have some one key it up and feel line surge with fuel...sound like it tho...hey try this...look at your fuel lines...just looked and seen you swapped it...Fuel Pressure Regulator FPR is your RETURN line if there backwards it WILL NOT run...Hope thats it!Good luck!http://www.jnrmotorsports.net

canari
Posts: 1
Joined: Wed Sep 12, 2007 4:37 pm
Car: 91 240sx
Contact:

Re: ka24de idles step on gas dies?!?!?!? (DRIFTN_SILVIA13)

Postby canari » Wed Sep 12, 2007 4:51 pm

yo man wusup?if it dies when u give it gas first check your maf sensor.disconect it clean the terminal and use some crc maf cleaner 2 clean the inside.make sure the connector is not upside down

DRIFTN_SILVIA13
Posts: 28
Joined: Mon Sep 10, 2007 10:13 am

Re: ka24de idles step on gas dies?!?!?!? (Toadstool)

Postby DRIFTN_SILVIA13 » Thu Sep 13, 2007 1:58 pm

Toadstool wrote:Do you have fuel to the engine?Fuel Pressure Regulator FPR is your RETURN line if there backwards it WILL NOT run...Hope thats it!Good luck!http://www.jnrmotorsports.net
i check the fuel line going into the fuel rail. and they are correct. today in the morning it reved up to 2000rpm. then after i would give it throttle and would die. the fuel pump does prime when the ignition is on. so i am stumped.

any other ideas please.

nissan2.4
Posts: 27
Joined: Sat Sep 08, 2007 8:36 pm
Car: 91 240SX hatch N/A KA
brian crower stage 2 cams
obx headers
custom cold air intake
removed cat, egr valve, anti swirl valves

Re: ka24de idles step on gas dies?!?!?!? (DRIFTN_SILVIA13)

Postby nissan2.4 » Thu Sep 13, 2007 2:28 pm

It sounds like ur distributor is off a couple of teeth. Easiest way to figure out if this is ur problem is, removed both bolts that hold ur dist in place, start ur engine and rotate the dist clockwise or counter and see if it gets better, if it does, ur dist is off some teeth. This is the most common problem with the KA, especially since you say its a different motor. The reason why this is very common is cuz on the KA, the dist and the idler gear for the cams has teeth all around and they are al the same, so the dist can go on any way Just one tooth of and it will not run good. Many other engines have slots on the cam which the dist can only go on one way. Lucky US!!

User avatar
ZOOMIGUEL
Posts: 181
Joined: Thu Jun 14, 2007 4:02 am
Car: 1989 240sx SR20DET
2006 Lexus IS250 AWD
Contact:

Re: ka24de idles step on gas dies?!?!?!? (nissan2.4)

Postby ZOOMIGUEL » Sat Sep 15, 2007 5:59 pm

check hoses from cold air intake to block. if one is slit, it causes car to die immediaetly when acceleration is given.

check all hoses , because the smallest tear could be the biggest problem

Chucez
Posts: 54
Joined: Wed Sep 06, 2006 6:13 am
Car: 1971 PL510 Station Wagon, 1989 AE92 GT-S

Re: ka24de idles step on gas dies?!?!?!? (ZOOMIGUEL)

Postby Chucez » Sat Sep 15, 2007 6:51 pm

ZOOMIGUEL wrote:check hoses from cold air intake to block. if one is slit, it causes car to die immediaetly when acceleration is given.

check all hoses , because the smallest tear could be the biggest problem
which hose are you talking about? I'm having the same problem. But Mine won't even reach 2k rpm. if you even touch the throttle, it sputters then dies. I'm stumped as to what vacuum hoses to check because i already took off the egr (except the vacuum lines going to the egr).

DRIFTN_SILVIA13
Posts: 28
Joined: Mon Sep 10, 2007 10:13 am

Re: ka24de idles step on gas dies?!?!?!? (ZOOMIGUEL)

Postby DRIFTN_SILVIA13 » Sun Sep 16, 2007 7:56 pm

ZOOMIGUEL wrote:check hoses from cold air intake to block. if one is slit, it causes car to die immediaetly when acceleration is given.

check all hoses , because the smallest tear could be the biggest problem
would a slit on the brake booster hose connected to the intake manifold would be the cause?

Toadstool
Posts: 72
Joined: Sat Dec 16, 2006 1:49 pm
Car: blown up, 240's

Re: ka24de idles step on gas dies?!?!?!? (DRIFTN_SILVIA13)

Postby Toadstool » Mon Sep 17, 2007 3:59 am

yup...huge vacuum leak...good find bro...remove and replace line and go drive that pig...

DRIFTN_SILVIA13
Posts: 28
Joined: Mon Sep 10, 2007 10:13 am

Re: ka24de idles step on gas dies?!?!?!? (Toadstool)

Postby DRIFTN_SILVIA13 » Wed Sep 19, 2007 2:25 pm

well i replaced the brake booster hose. but its still doing the same thing. i checked everything now i have no clue what it could be.

rocketbunny808
Posts: 1
Joined: Sat Jun 08, 2013 5:37 pm
Car: 240sx s13 ka24e

Re: ka24de idles step on gas dies?!?!?!?

Postby rocketbunny808 » Sat Jun 08, 2013 5:42 pm

did you ever find out what the issue was? i have the same problem right now, happened the day after i used injector cleaner, it will rev up to about 1500-2000 rpm then die, other wise it will start and idle fine, fuel pump primes no problem, fuel filter replaced, my next move is to clean the maf and replace the fuel pressure regulator but im really stumped haha

420blazeleo
Posts: 2
Joined: Wed Jul 22, 2020 12:30 pm
Car: 1993 Nissan 240sx (S13)

Re: ka24de idles step on gas dies?!?!?!?

Postby 420blazeleo » Wed Jul 22, 2020 8:30 pm

any chance you found out what it was? im having the same issue with my 93 s13... i havent messed with anything yet trying to find the most probable cause before i do something


Return to “KA24E / KA24DE Forum”