JX35 high speed surging

Discussion forum for the Infiniti JX35 / Infiniti QX60 - This 7-seat premium crossover dominates the class.
mnummy
Posts: 8
Joined: Fri Jun 17, 2016 7:37 am
Car: JX35

JX35 high speed surging

Postby mnummy » Mon Sep 17, 2018 6:20 am

I have owned this beast for about 2 years. I have been plagued with the "normal" CVT operation of changing "ratios" (God forbid you say gears) since owning this car. In the shop several times due to the fact I KNOW this is not normal. But I've lived with it.

Now, after the car has heated to operating temperature, it will surge at highway speed. The tack with go from about 2k to 3.5k and back over and over it will never settle in to the normal approx. 2k. It's as if the transmission is slipping and won't fully engage. However, if you set the transmission to manual, it will continue to do this in "gear" 5 and 6. But if you shift it to 4 and leave it it will run at a constant 3k rpm (which I would assume was about right). I was on the interstate yesterday when it started and I drove it for miles without moving my foot on the accelerator and the shift knob set to automatic. It never stopped doing it.

Has anyone had such an experience with these vehicles? Needless to say this is not my favorite vehicle. In my opinion NICO missed the mark on this one...terrible gas mileage, slightly under powered, and when you get 2 adults in the middle row you have to adjust your headlights to not point at the sky.

Sorry for the venting. I know my opinion differs from most probably and that is fine. I just want to know what it will take to fix this new surging issue.


Return to “Infiniti JX35 / QX60 Forum”

cron