Intermittent low idle at start - engine noise when under load - connected?

The G-Series Tuning Forum is the place to discuss G35/G37 performance modifications and mechanical repair.
iCapture
Posts: 23
Joined: Sun May 18, 2008 3:47 pm
Car: 2011 G37S

Intermittent low idle at start - engine noise when under load - connected?

Postby iCapture » Mon May 01, 2017 4:37 pm

Hey guys,

11' G37S owner here. So every now and again when I start the car the idle goes really low, and on very few occasions has shut off. I figured this was a MAF issue.

But there is one other issue going on and I was wondering if they are somehow connected. When under load at low RPM's, for instance when I'm just driving casually and a big hill comes around, when it slowly press the accelerator a weird noise comes from the engine. Its not exactly a knock, but kinda sounds like it. When I drive up hills at a high rpm the noise is absent. It also could just be that the increased volume of the engine is drowning it out.

I was wondering if this is a known issue and if it could be connected to an air flow issue? I am selling soon and I'd like to get everything working lovely before that time.


User avatar
centralcoaster33
Posts: 2769
Joined: Tue Apr 05, 2005 10:41 am
Car: 240SX #5-1997
Location: Central Coast, CA

Re: Intermittent low idle at start - engine noise when under load - connected?

Postby centralcoaster33 » Tue May 02, 2017 12:37 pm

Have you checked your cars computer for codes with a scanner of some sort? You can use your own, borrow a friends or co-workers, or go to a parts store like AutoZone and have them scan it for free. If no codes, check your fluid levels for everything, have your battery and alternator tested, look for vacuum leaks, disconnected hoses, wires or sensors. Finally, consider any recent repairs you may have had (like throttle pedal or sensors). Please let us know what you find or remember.


Return to “G35 and G37 Engine, Drivetrain & Tuning”