Fluctuating Rpms then engine dies

Covering the 2003-2015 first-gen and 2016+ Titan and Titan XD lineup
TitanIssuesX100
Posts: 1
Joined: Sun Jul 31, 2016 5:44 pm
Car: 2007 Nissan Titan king cab 4wd

Fluctuating Rpms then engine dies

Postby TitanIssuesX100 » Sun Jul 31, 2016 6:04 pm

Hello everyone,

New to the site I came across it trying to fix my Nissan Titan. So I guess I'll start with what's been going on then just list the issues in order they happened.

I have a 2007 Nissan Titan King cab 4wd, it has roughly 146,500 miles on it. I bought it two months ago just as a work truck and it was in great shape, I test drove it and did great. Check the engine out, no noises from under the hood and so I bought it. It had a full tank of gas when I left the dealership, I got all the way without issue and as soon as pulled up to my house which has an incline of about 10 degrees I could not get the car to come back on after turning it off. Well the gas gauge read full still however, I called the dealership and they had it towed back there no charge to me, took a look at everything and found that the gas gauge was broken and stuck on full when I was actually out of gas. So the mechanic there said he installed a new wire (I think) to fix the gauge and I was on my way, I drove for weeks without issues. Now here's where I am confused and not sure if this wire had something to do with it or not that's why I explained all that but anyway:
Turn the engine on in the morning and it runs greats for about 5-7 mins
The check engine light comes on
Rpms start to fluctuate between 1000-5000 BY ITSELF
Smells like gas but I assume it's from the engine revving itself up
The SLIP light comes on
Then the engine dies.
Now I have a scanner and checked the codes which came back with Evap sensor shorted, engine coolant temperature sensor high, intake sensor high, fuel sensor high. If anyone needs the actual codes let me know I will go re scan and get them.
I replaced the engine coolant temp sensor and then cleared the codes, that was the only one I could get ahold of. Well it didn't work and CEL light came back on with all the same codes including that sensor. So I looked on this forum and found two things to try, clean the MAF and the throttle, so I did, they both look brand new, this didn't help at all. I also cleaned the cables going to the battery. In order to get the engine to restart I have to continuously press the accelerator, as soon as I stop pressing the Rpms fluctuate again and then it dies.. This is driving me insane. Please help me! Sorry for the long post.


User avatar
Desert Rat
Posts: 1929
Joined: Wed Jan 17, 2007 11:57 am
Car: 2014 370Z M6 Base Coupe
2017 Frontier 4.0
2007 Dodge Ram 2500 Cummins Quad Cab 4x4
1977 F150 4x4 Shorty BUILT
2008 Boulevard C90T
Previous owner of a bunch of Nissans
Location: Mesa, AZ
Contact:

Re: Fluctuating Rpms then engine dies

Postby Desert Rat » Tue Aug 02, 2016 1:45 pm

most dealerships have a 3 day right of recision....if it were me that sucker would be going back and I'd be hunting for a refund


Return to “Nissan Titan Forum”