downstream o2 sensor question

Forum for Infiniti M35 and M45, and Nissan Fuga owners.
eyedeekay
Posts: 17
Joined: Tue May 21, 2019 6:14 pm
Car: 2006 Infiniti m35

downstream o2 sensor question

Postby eyedeekay » Sun Jun 23, 2019 8:29 pm

I have a 2006 m35 and the driver side cat went bad alongside the o2 sensor, so I decided to replace both the passenger and driver side downstream o2 sensors along with the cats. However, the new sensor for the driver side is apparently faulty, its giving me a p0057 code and data recording supports this from the obdii scanner app. My question is: are the passenger and driver side downstream o2 sensors interchangeable (the blue and green plugs)? The old passenger o2 sensor apparently still works and I would rather not have to buy a new o2 sensor again :)


User avatar
Ilya
Moderator
Posts: 9068
Joined: Fri Apr 23, 2010 11:20 pm
Car: 2011 M56x but I spend a lot of time on my 2015 Kawasaki Vulcan S. Former owner of a 2007 M35x. Also take care of my wife's 2016 QX60.
Location: Albany, NY
Contact:

Re: downstream o2 sensor question

Postby Ilya » Mon Jun 24, 2019 6:01 am

I do not believe they are as if I recall, the part numbers are different. You can cross reference this by using a parts site like InfinitiPartsOnline.com or something.

Now, that doesn't also mean that different part numbers = different parts but in my experience it does. For my wife's new 2016 QX60, there are 2 sensors who share the same part number and 2 others who have different part numbers.

eyedeekay
Posts: 17
Joined: Tue May 21, 2019 6:14 pm
Car: 2006 Infiniti m35

Re: downstream o2 sensor question

Postby eyedeekay » Mon Jun 24, 2019 8:18 pm

Ilya wrote:
Mon Jun 24, 2019 6:01 am
I do not believe they are as if I recall, the part numbers are different. You can cross reference this by using a parts site like InfinitiPartsOnline.com or something.

Now, that doesn't also mean that different part numbers = different parts but in my experience it does. For my wife's new 2016 QX60, there are 2 sensors who share the same part number and 2 others who have different part numbers.
Ok, so after long hours today I have found that the "faulty" o2 sensor indeed actually works, however the male connector harness for the driver side is somehow broken, the o2 sensor sometimes "works" and then decides to stop working :confused:. I will keep updated if I find a fix to this w/o resoldering a whole new connector


Return to “Infiniti M35 and M45 Forum”