Dash and AC lights not working

ONLY for ADVANCED technical discussion about the 240sx!
DarkSlide77
Posts: 13
Joined: Sat Dec 30, 2017 7:14 pm
Car: S13 coupe 1993

Dash and AC lights not working

Postby DarkSlide77 » Tue Jun 25, 2019 7:03 pm

I’ve searched for a long long time but I’ve finally given up. I’ve checked ALL my fuses and even tried to solder my TCU, however, my TCU looked perfect. I can’t find the reason why my dash lights won’t work. I’ve heard of taking the red with yellow line wire and “supplying a ground” for it and that’s how others have resolved this problem. I’m not even sure how to do that. Any help at all, seriously any at all, would be greatly appreciated. Thank you


User avatar
zerepdivad
Posts: 2007
Joined: Thu Nov 24, 2005 5:39 pm
Car: '90 240sx . '02 Lexus IS300
Location: Elkhorn, WI

Re: Dash and AC lights not working

Postby zerepdivad » Wed Jun 26, 2019 6:50 am

Are you talking about your illumination lights that light up when you turn the headlights on and whatnot?

DarkSlide77
Posts: 13
Joined: Sat Dec 30, 2017 7:14 pm
Car: S13 coupe 1993

Re: Dash and AC lights not working

Postby DarkSlide77 » Wed Jun 26, 2019 12:08 pm

zerepdivad wrote:
Wed Jun 26, 2019 6:50 am
Are you talking about your illumination lights that light up when you turn the headlights on and whatnot?
Yeah, the Speedo and rpm cluster lights as well as most of my AC lights. Funny thing is a couple lights on on my Speedo and AC actually work but 80% of them are off.


Return to “240SX Technical Forum”