Check Engine light & TCS off & SLIP lights on constantly

The club for Nissan Maxima and Infiniti I30 / I35 owners, and the official home of Maxima Club of America!
3charlie3
Posts: 3
Joined: Thu Mar 15, 2012 8:48 am
Car: 2003 Nissan Maxima GLE

Check Engine light & TCS off & SLIP lights on constantly

Postby 3charlie3 » Thu Mar 15, 2012 8:57 am

My 2003 Maxima stalled while in motion, car did restart but Service Engine Soon Light and TCS off light and SLIP light all are on, and have been constantly. Car is now hard to start cold or warm, but once it starts it runs fine. Gas mileage became very poor since these lights came on, and my Traction Control system no longer works. I have not had diagnostics performed as yet, but I have read many other posters' complaints of the same issue.


User avatar
loystock
Moderator
Posts: 2143
Joined: Sun Sep 21, 2003 9:12 pm
Car: 10 Pilot, 97&03 Q45s, 97 I30 and 06 M35 Sports (04 G35 & 99 I30-RIP)
Location: San Jose, CA

Re: Check Engine light & TCS off & SLIP lights on constantly

Postby loystock » Thu Mar 15, 2012 12:38 pm

Welcome to NICO.

A classic symptom of a failing alternator. With the engine off, if the battery is good and assuming the alternator has charged it properly, voltage should be >12.6 VDC. With the engine running, check that the voltage is stable and is >13.8 VDC (spec is 14.1-14.7 VDC). Do not run the car in this condition as you can get stranded somewhere or even damage some electrical components.

3charlie3
Posts: 3
Joined: Thu Mar 15, 2012 8:48 am
Car: 2003 Nissan Maxima GLE

Re: Check Engine light & TCS off & SLIP lights on constantly

Postby 3charlie3 » Thu Mar 15, 2012 2:22 pm

Thank you, but am I to check the Battery or the Alternator's voltage ?

User avatar
loystock
Moderator
Posts: 2143
Joined: Sun Sep 21, 2003 9:12 pm
Car: 10 Pilot, 97&03 Q45s, 97 I30 and 06 M35 Sports (04 G35 & 99 I30-RIP)
Location: San Jose, CA

Re: Check Engine light & TCS off & SLIP lights on constantly

Postby loystock » Fri Mar 16, 2012 12:24 pm

Both - battery with engine off; alternator with engine running.

3charlie3
Posts: 3
Joined: Thu Mar 15, 2012 8:48 am
Car: 2003 Nissan Maxima GLE

Re: Check Engine light & TCS off & SLIP lights on constantly

Postby 3charlie3 » Fri Mar 16, 2012 12:57 pm

Thanks.........

GEOMO
Posts: 1
Joined: Mon Oct 01, 2018 3:20 pm
Car: 2005 Nissan Maxima SE

Re: Check Engine light & TCS off & SLIP lights on constantly

Postby GEOMO » Mon Oct 01, 2018 3:35 pm

My 2005 Maxima did the exact same thing. Figured it was was the alternator since battery totally died and alternator check came back bad.
Car started and drove, but lacked any kind of power, also tach wouldn’t get passed 2100rpm until speed was faster than 30mph and then seems to perform almost normal. At this point no MIlS were on. Got home, parked it, checked the trans fluid, it was low.
Got back in to restart and this time all the lamps were on: Slip, TCS and check engine soon.
So i drained the trans fluid and added till full (with Nissan fluid of course). With the engine running and parked I ran through the gears and kept rechecking.
But then all of sudden then engine cut off and hasn’t been able to restart since.
Please help


Return to “Maxima Forum & I30 / I35 Forum”