CA18DET making some weird noises

ONLY for ADVANCED technical discussion about the 240sx!
200sxTony
Posts: 1
Joined: Sun Mar 01, 2020 2:38 pm
Car: ???

CA18DET making some weird noises

Postby 200sxTony » Sun Mar 01, 2020 3:46 pm

ive searched and searched but cant come up with a definitive answer... ive got a 91 240sx with a CA18DET swap, car is relatively stock other than the normal bolt ons...intake, z32 maf, FMIC etc etc...was out driving the car the other night and after a few hard pulls(not back to back to back) the car started to make a weird flutter as it hits boost, the noise wouldn't go away so i parked the car for the night...i started the car up the next day totally normal(other than the cars normal rough idle)...warmed the car up, car revs fine no weird noises at all...went for a drive did a pull or 2 just to have the noise come right back...the noise is most noticeable while the car is driving and under any load, if the car is parked it will only make the noise if you SNAP the throttle...if you pop the hood and stick your head under there, slowly pulling throttle doesn't make the sound...ONLY while SNAPPING the throttle the noise is VERY quiet almost not even noticeable...it sounds like its coming from the turbo side of the engine. it doesn't really sound like a spun bearing maybe a Big End on the way out???? but even then i couldn't find any videos of bad big ends that sounds like mine...it just doesn't sound like rod knock...Thank you in advance :bigthumb:


User avatar
NukeKS14
Posts: 123
Joined: Wed Apr 10, 2019 2:50 pm
Car: 1995 240SX SE - KA24DE-T
2014 Camaro SS 1LE

Re: CA18DET making some weird noises

Postby NukeKS14 » Thu Mar 05, 2020 2:34 pm

You running an HKS BOV? Sounds like you may be describing turbo flutter...

User avatar
PapaSmurf2k3
Site Admin
Posts: 23256
Joined: Thu Nov 21, 2002 3:20 pm
Car: 2017 Corvette, 2018 Focus ST, 2001 Miata turbo, 1993 240sx truck KA Turbo.
Location: Oxford, MS
Contact:

Re: CA18DET making some weird noises

Postby PapaSmurf2k3 » Mon Mar 16, 2020 8:38 pm

Yeah look for blow off valve weirdness, and maybe a boost leak or vacuum leak somewhere. Could be causing funky stuff to happen.


Return to “240SX Technical Forum”