Boost gauge and tourqe guages not reading

The web's first forum dedicated to the Nissan Juke and the Nissan Qazana.
silfortysx719
Posts: 41
Joined: Fri Sep 17, 2010 7:42 pm
Car: 2011 juke 26080 miles

Boost gauge and tourqe guages not reading

Postby silfortysx719 » Thu Feb 24, 2011 1:15 am

My juke is only two months old and i dont drive it like its a race car or anything but lately when i put it in sport mode the gauge on the icon system only reads half boost even when the gas is pinned same with the tourqe any one else have this problem its very annoying :mad:


User avatar
GRey1
Posts: 120
Joined: Tue Nov 02, 2010 7:06 am
Car: 2015 Gun Metallic SL AWD w/Tech
2011 Chrome Nissan Juke SV CVT-AWD
Location: The Burbs of Cleveland

Re: Boost gauge and tourqe guages not reading

Postby GRey1 » Mon Feb 28, 2011 10:19 am

Several days and NO replies? I can tell you that this is not the case with my car. I find it difficult to not to peg the boost when in Sport mode. Seems like you just tap the pedal and the boost pegs. If you haven't taken it in to get looked at already, I would suggest doing so. There is definitely something wrong there.

User avatar
Ace2cool
Posts: 12672
Joined: Sun Apr 20, 2008 5:21 pm
Car: 1991 Nissan 300ZX TT
1966 Datsun Fairlady 1600
2005 Suzuki GSX-R 600
1974 Honda CB550 Four
2009 Ford F150 Lariat
Location: Murfreesboro, TN

Re: Boost gauge and tourqe guages not reading

Postby Ace2cool » Mon Feb 28, 2011 2:44 pm

When my boost gauge stopped reading on my TT, turned out to be a vacuum cap had blown off during boost. found a cap, capped it, and has been fine ever since. Not sure about the torque gauge, but I'd suggest looking for a boost leak.

silfortysx719
Posts: 41
Joined: Fri Sep 17, 2010 7:42 pm
Car: 2011 juke 26080 miles

Re: Boost gauge and tourqe guages not reading

Postby silfortysx719 » Fri Mar 04, 2011 4:27 pm

yeah it feels like a boost leak


Return to “Juke Forum | Qazana Forum”