Bluebird T12 (1990)

Discussion forum for the venerable 510, and its non-US counterparts, the Datsun 1600 and Bluebird.
teoliciu1
Posts: 2
Joined: Sun Dec 18, 2016 2:15 am
Car: Nissan Bluebird U12 1990

Bluebird T12 (1990)

Postby teoliciu1 » Sun Dec 18, 2016 2:42 am

Hi! Just recently bought a Bluebird T12 and tried to get her into shape since the other guy didn't care much about her. But I've got a problem with the cooling system, or I think I have. The cooling tank in its upper side doesn't have the hose connected just like in this image.

Image

Is it normal to be like that, or not?
Last edited by Rogue One on Sun Dec 18, 2016 7:58 am, edited 1 time in total.
Reason: Moved to correct forum


User avatar
Rogue One
Moderator
Posts: 7392
Joined: Tue Jun 14, 2011 10:15 pm
Car: 2011 Nissan Rogue SL
2012 Nissan Rogue SL
2012 Honda CR-V LX
Location: Florida, USA

Re: Bluebird T12 (1990)

Postby Rogue One » Sun Dec 18, 2016 8:27 am

Welcome to NICO!

I've moved your topic to the Bluebird section. I would normally suggest checking the FSM, but as yet we don't seem to have one for your vehicle. You might find some useful info in the CA18DE / CA18DET Forum

Not sure about the missing hose, so hopefully someone that's more familiar with it can chime in.

teoliciu1
Posts: 2
Joined: Sun Dec 18, 2016 2:15 am
Car: Nissan Bluebird U12 1990

Re: Bluebird T12 (1990)

Postby teoliciu1 » Sun Dec 18, 2016 8:45 am

Thanks for the tip but its a CA16S engine, either way its worth checking out.


Return to “Datsun 510 / Bluebird”