Blackvue DR400G-HD II and Power Magic Pro in G37

Discussion forum for body kits, repair, modifications, interior styling, Audio / Video and internal/external lighting.
Cgrossmeier
Posts: 3
Joined: Tue Jan 01, 2013 1:42 pm
Car: 2009 Infiniti G37X
2012 Infiniti EX35 Journey AWD
Location: Minneapolis, MN
Contact:

Blackvue DR400G-HD II and Power Magic Pro in G37

Postby Cgrossmeier » Tue Jan 01, 2013 2:11 pm

I recently picked up a BlackVue dash camera and accessory power kit, the Power Magic Pro to use as an added car security feature. The Camera works great when plugged in to the cigarette lighter socket, but I have had nothing but trouble with the Power Magic Pro.

I picked up 2 Add-a-Circuit kits. One for the Battery wire and one for the accessory wire. I have the Battery lead connected to the 10A Elect Parts (BAT) fuse slot and the Accessory lead connected to the 15A Power Socket fuse slot. The ground is grounded to the screw near the hood release.

My issue is the green power light for the Power Magic Pro never comes on and no power is delivered to the Blackvue Camera. I've tried a few different ground point, battery fuse slots, and accessory slots. The devices powered by these slots are getting power, but the Power Magic Pro does not. Tried the stop lamp, room lamp, mirrors, power socket, Meter (BAT) slots with no success. If I tap the ground wire to a ground source the green light illuminates for a fraction of a second then goes if.

I cannot get this device to work.

Has anyone else used / installed the Power Magic Pro in the Infiniti G37 and had any success?


User avatar
audtatious
Moderator
Posts: 36942
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby audtatious » Thu Jan 03, 2013 12:26 pm

have you tried connecting it to something else to see if the issue is really with the car and not the product itself?

Cgrossmeier
Posts: 3
Joined: Tue Jan 01, 2013 1:42 pm
Car: 2009 Infiniti G37X
2012 Infiniti EX35 Journey AWD
Location: Minneapolis, MN
Contact:

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby Cgrossmeier » Tue Jan 15, 2013 4:20 pm

I would, but both of my cars are Infiniti. :) Same issue on the EX35. I can tap the ground cable to the frame, and I can get the light to flash, but the power is immediately cut. Not sure if it is happening on the Infiniti side or from the Blackvue. Blackvue has been ZERO help on the matter. Tried to Power Magic Pro's and had the same issue with both. Ended up just pulling the device.

The funny thing, my PASSPORT radar detector is wired in and works fine. Using ACC Outlet fuse and ground under the dash without issue. Both Blackvue Power Magic Pro's won't turn on or keep power.

User avatar
audtatious
Moderator
Posts: 36942
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby audtatious » Tue Jan 15, 2013 7:28 pm

Have you tried connecting it directly to the battery and see if it will power up at all? Sounds like the connections are OK if your radar detector is working.

Thinking the unit may be bad if it dies regardless of where you hook it up.

Dunno, been a long day.

sor326
Posts: 8
Joined: Sun May 24, 2009 1:13 pm

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby sor326 » Thu Apr 09, 2015 12:53 pm

I hate to revive a dead thread but I just purchased a Blackvue 650 and Power Magic Pro. I am having the same issue! Did you ever figure out what was wrong? Maybe it could help me trouble shoot as well.

djdiskino
Posts: 1
Joined: Mon Jun 01, 2015 8:39 pm
Car: G37x 2011 Sedan

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby djdiskino » Mon Jun 01, 2015 8:43 pm

Also reviving this thread as well.. having the same exact problem OP or previous reviver - did you ever get it working?

I tested my power magic pro with a jumper battery in my garage and all works well.. but on the G37x it flashes the light for a second then shuts off.. I wonder if it's the voltage of my battery or the dip switches. I'll look at that next and post back my findings as to help anyone else out if I get it working.

Cgrossmeier
Posts: 3
Joined: Tue Jan 01, 2013 1:42 pm
Car: 2009 Infiniti G37X
2012 Infiniti EX35 Journey AWD
Location: Minneapolis, MN
Contact:

Re: Blackvue DR400G-HD II and Power Magic Pro in G37

Postby Cgrossmeier » Mon Aug 20, 2018 8:47 pm

I never got it to work... Ended up with a Lithium-ion battery pack with a 12v output. I plugged the battery into the center console 12V port and it charges while the car runs. The Camera is now running to this battery with a 12V out port in the console.

Curious if anyone ever got the Power Magic Pro BlackVue working with an Infiniti.


Return to “G35 and G37 Interior, Exterior and Audio”