Audio Problems...

Discussion forum for body kits, repair, modifications, interior styling, Audio / Video and internal/external lighting.
SeveLampley
Posts: 34
Joined: Tue Feb 18, 2020 8:04 am
Car: 2007 Infiniti M35-k23 silver, 5 stage paint correction, 2 ceramic coats, full bolt on, uprev tuned, d&s rotors, hawks hs1 pads, dot 5.1 steel lines

Audio Problems...

Postby SeveLampley » Mon May 17, 2021 6:18 am

Hey, 2003 Infiniti G35 Sedan, Bose Audio package on it. I plan on doing a full system in this car, but in the mean time, the reception I’m getting is crap, like really bad. I have only gotten audio on a couple of stations and even then, it eventually goes out. Brand New Amp in the back. Took the HU out and it the resistors don’t look fried. On the other stations all I get are pops when I try to turn it up. FM Transmitter can’t even be found. Could this be an issue with the antenna or more of the wiring? I guess what I’m asking is has anyone else had this problem, and what does each plug on the back of the HU do.
On a separate note, to get to the Headunit, I broke the Clock dash trim, every single clip stayed in... What is the best solution for that, I see the aluminum trim kits, but 1.)I only need the clock trim
2.) I’m breaking down and getting the Metra Double din kit, and I’d like it to match....


User avatar
VStar650CL
Posts: 2015
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: Audio Problems...

Postby VStar650CL » Mon May 17, 2021 6:31 am

If you're getting any stations at all then it's almost certainly an antenna problem. The AM/FM antenna on almost all N/I head units will be a gray stand-alone plug with 1 or 2 wires (depending if it's shielded, some aren't).

SeveLampley
Posts: 34
Joined: Tue Feb 18, 2020 8:04 am
Car: 2007 Infiniti M35-k23 silver, 5 stage paint correction, 2 ceramic coats, full bolt on, uprev tuned, d&s rotors, hawks hs1 pads, dot 5.1 steel lines

Re: Audio Problems...

Postby SeveLampley » Thu May 20, 2021 1:41 am

VStar650CL wrote:
Mon May 17, 2021 6:31 am
If you're getting any stations at all then it's almost certainly an antenna problem. The AM/FM antenna on almost all N/I head units will be a gray stand-alone plug with 1 or 2 wires (depending if it's shielded, some aren't).
That’s the thing, I get it, for a few seconds, then it cuts out, and then there’s a pretty constant pop that happens of the volume is up i know bottom ribbon is on it last legs, but works when it’s taped down. I just got the car and it looks like the c-pillar might haven been dug into but I can’t say for sure, but is previous owner when through the trouble on s***-ly installing a new amp(didn’t even bolt it up...) then I’d imagine he would have already checked there(maybe didn’t know what he was looking for?..) also, not familiar with 2003-2005, is the drivers footwell fuze box supposed to be a wasp nest.... can’t tell if it’s factory and someone didn’t bother putting it back correctly or if the s*** has been messed with.. the guy I bought it from didn’t know cars let alone Infiniti’s, gave me a list of suspension parts he said needed replaced Bc of “coilovers” but those parts look damn near new but the lower control arm bushing(or whatever it’s called, goes from LCA to “frame”) is complete out and banging against the side... yet he bought 2500$ tein coilovers...


Return to “G35 and G37 Interior, Exterior and Audio”