Ambient Temperature Sensor

Forum for Infiniti M35 and M45, and Nissan Fuga owners.
whitediamond642
Posts: 22
Joined: Sat Feb 09, 2008 4:28 pm
Car: 2003 Infiniti I35
2007 Infiniti M35X

Ambient Temperature Sensor

Postby whitediamond642 » Mon Sep 26, 2011 2:49 pm

Firstly, information about my vehicle:
2007 M35X with Nav and Advanced Tech Pkg (LWD, Adaptive CC, etc.)

When I got the car, the A/C did not function properly, but I immediately noticed that the exterior temperature (according to the car) was -22 degrees.

I removed the bumper and found the ambient temperature sensor was not there. I removed the one from my wife's I35 and it read correctly.

My question is whether anyone has pulled this sensor from an older car (I30/35 or older Max), put it in the M and had any issues with it?

They appear to all use the same harness and I'm just trying to save a few buck by pulling one from a pick n' pull and plugging it in. I figure they can't have changed the senser that much since the body design doesn't appear to have changed.

Just curious.

Thanks.

William


User avatar
szh
Moderator
Posts: 18857
Joined: Tue Jul 23, 2002 12:54 pm
Car: 2018 Tesla Model 3.

Unfortunately, no longer a Nissan or Infiniti, but continuing here at NICO!
Location: San Jose, CA

Re: Ambient Temperature Sensor

Postby szh » Tue Sep 27, 2011 9:25 am

Hmmm ... not sure of the answer to your question, but I would recommend checking the web site for Everything Infiniti (link is in my web site) and see if the part numbers are the same for many of them.

Or give them a call and speak with Joe Tsensky. He is very helpful to us NICO folks.

The service manual (link is also in my sig) may also be a source of information.

Z

whitediamond642
Posts: 22
Joined: Sat Feb 09, 2008 4:28 pm
Car: 2003 Infiniti I35
2007 Infiniti M35X

Re: Ambient Temperature Sensor

Postby whitediamond642 » Sun Oct 16, 2011 9:16 pm

I ended up replacing the ambient temp sensor with one from a 99 Max. AC works fine now, but I just posted in anothe thread that my M is now in limp mode. I wouldn't think they are related issues, but if I can't get it figured out I'll unhook the temp sensor and see if that's it since that and a new headlight ballast are all that I changed.

dlduscg
Posts: 58
Joined: Tue May 08, 2007 3:33 am
Car: 1999 Infiniti Q45

Re: Ambient Temperature Sensor

Postby dlduscg » Mon Jan 20, 2020 1:28 pm

I had a loud hi frequency squeal coming from the front grill of my 2009 FX35 with the ignition off which persisted for more than 36 hours. The sound was unbearable and was heard up and down the street as far as a city block away. The only other symptom I had was the dash display which shows the outside temperature showed only ICY and three dashes where the temp is supposed to appear (---) and F (for farenheit). The sound came directly where I believed the sensor is located (right front lower grill area). I didn't need to use the car and the sound was muted when inside my house so I planned to take it in to the dealer Monday morning, but the next day it just stopped, and I haven't had the problem again. Now that I know the location of the sensor, if it happens again, I will pull it out and replace it. However, in the case of the missing sensor, it may be that is why it was missing. As far as I can find, there is no TSB or recall on the part, and I can find no one else who had the problem.

dlduscg
Posts: 58
Joined: Tue May 08, 2007 3:33 am
Car: 1999 Infiniti Q45

Re: Ambient Temperature Sensor

Postby dlduscg » Mon Jan 20, 2020 1:37 pm

I forgot to mention that the AC was not working, but the fan was blowing warm air and I assumed the sensor was likely the problem, because when the screeching stopped, the AC was working, and its been working fine ever since. I hope this was a glitch of some kind, but knowing that things do not usually fix themselves, I am bracing for it to happen again, and will get a spare just in case.


Return to “Infiniti M35 and M45 Forum”