Alternator Problems!

ONLY for ADVANCED technical discussion about the 240sx!
User avatar
Anand
Posts: 6519
Joined: Tue Jul 23, 2002 5:31 pm

Alternator Problems!

Postby Anand » Wed Jul 24, 2002 4:34 pm

Have you guys had problems with your alternator?? I recently just had my alternator go out on me and you know... I had my AirBag sign started to flash right before my car shut down. I thought that was really weird. But didn't think anything of it. This was a month ago and then just 2 days agao, my AirBag light started to flash again and I put up a thread on the 240sx.org site for it and someone told me that there must be something wrong with my AIrBags!! duh... but actually.. my alternator went out again...it was my car trying to tell me that I need to get it to a mechanic or else my car will shut down again since it was runnin on the battery. has anyone else seen this weid sign??? :confused:


User avatar
AunVoh
Posts: 560
Joined: Wed Jul 24, 2002 7:47 am
Contact:

Postby AunVoh » Wed Jul 24, 2002 4:34 pm

i've never heard of such a thing, i had my alt go out on my old S13 once, but it didnt have a air bag, so i'd say just to have nissan check it out :(

heres a thought, maybe the air bag system has a short in it somewhere and is making your alt's go bad?

User avatar
Anand
Posts: 6519
Joined: Tue Jul 23, 2002 5:31 pm

Postby Anand » Wed Jul 24, 2002 4:34 pm

Hmmm.... That definetly is something to think about!!! damn... I never thought of that! GREAT. I am gonna have to take it in now. :mad:

juazam_186
Posts: 69
Joined: Wed Jul 24, 2002 12:57 pm
Car: Cars & Computers

Postby juazam_186 » Wed Jul 24, 2002 4:34 pm

Black,The alternator going bad or 'being' bad can cause some weird dash light to go "on".I've had to change my alternator once in almost 200k miles.I had two or three dash light flickering or turning on, but it was because of a bad diode in the alternator.Try to have your alternator checke 'outside' of your charging system, several stores will do this for free.Then, get a Good quality alternator for your car. Start with A.C.DELCO and move-on up from there.

juazam_186
Posts: 69
Joined: Wed Jul 24, 2002 12:57 pm
Car: Cars & Computers

Alternators, Part II

Postby juazam_186 » Wed Jul 24, 2002 4:34 pm

It is easiest to get to your alternator from underneath your car.I can do it in about 40 min's or so. Good luck.

ash1y1
Posts: 173
Joined: Thu Aug 22, 2002 9:18 am
Car: Cars, Gadgets & Gizmos, Computers, Health, Travel
Contact:

Curious

Postby ash1y1 » Wed Jul 24, 2002 4:34 pm

What site are you guys posting from? I post and read through 240.org, but I keep seeing people stating that 'you should go to 240.org", or "you should go to 240.org and post your question there." Do these forums connect multiple sites together?

User avatar
GodDrivesA240sx
Posts: 536
Joined: Tue Jul 23, 2002 4:37 pm
Car: 1995 Nissan 240sx
Contact:

Re: Curious

Postby GodDrivesA240sx » Wed Jul 24, 2002 4:34 pm

ash1y1 wrote:What site are you guys posting from? I post and read through 240.org, but I keep seeing people stating that 'you should go to 240.org", or "you should go to 240.org and post your question there." Do these forums connect multiple sites together?


these are the 240sx.org fourms

if you go to the site it has a popup that takes you to here. Well, atleast with the old nico it did, I'm sure they updated it.

Thesil
Posts: 140
Joined: Mon Aug 26, 2002 7:24 pm

MY CAR TOO

Postby Thesil » Wed Jul 24, 2002 4:34 pm

Did search this is the only thing i could pull up... the exact same thing happened to me and my alternator except mine flashed the battery light and the brake light on at the same time and gradually everything got dimmer inside the car and then the air bag light came on flashing while the others remained solid. Shortly afterwards my car died in the middle of the street.

now i am faced with the question of what to do with my alternator?

Can i use a sr20 alternator in perhaps a future swap?

What about an alternator from an earlier year ka such as a sohc ka?

Brand new it's going to cost my 280 bucks... i'd really like to find a temporary alternative for the time being....

User avatar
ricebike
Posts: 3350
Joined: Sat Feb 15, 2003 7:03 pm
Car: 89 240sx se 5spd 93 Honda Nighthawk 02 Quest
Location: CNJ
Contact:

Postby ricebike » Wed Jul 24, 2002 4:34 pm

get it from the junk yard & b4 installing, get it tested for free @ the parts stores... pepboys, autozone, etc...

User avatar
djtodd
Posts: 150
Joined: Sat Mar 15, 2003 9:41 am
Contact:

Postby djtodd » Wed Jul 24, 2002 4:34 pm

Yeah I had the same problem. ALternator died, replaced it, a day later the same thing happened.

It turned out that the large(4 ga) wired running to the battery form the alternator was corroded to nothing. I was just messing around and pulled on the end and it came off in my hand.

Needless to say that's something to check!

Btw, the second alternator was still good. I had it tested after replacing the wire and it was good to go.

180fan
Posts: 7954
Joined: Sat Dec 14, 2002 12:16 pm
Car: 89 fastback
Contact:

Postby 180fan » Wed Jul 24, 2002 4:34 pm

Whoa. Well I'm getting 2 lights on too, but my alternator already died and was replaced. It's still got the 2 lights on, the brake and very dimmly the battery light on all the time. Around 2k rpm, the brake light starts to buzz and goes out eventually, but when I let off the throttle it comes back to bright red. I've already started to get the parts to have the power system in the car replaced so hopefully it'll get rid of those problems.

User avatar
djtodd
Posts: 150
Joined: Sat Mar 15, 2003 9:41 am
Contact:

Postby djtodd » Wed Jul 24, 2002 4:34 pm

I'm telling ya, check that big wire. Would really suck to spend a lot of money and find out it was just a $20 wire! :D

Thesil
Posts: 140
Joined: Mon Aug 26, 2002 7:24 pm

Postby Thesil » Wed Jul 24, 2002 4:34 pm

Took your advice and got the alternator tested... turns out the alternator is fine but now the same lights are coming on again...

can you tell me what the wire is called and where i can get it?

i'd hate for the car to die on the highway....

User avatar
djtodd
Posts: 150
Joined: Sat Mar 15, 2003 9:41 am
Contact:

Postby djtodd » Wed Jul 24, 2002 4:34 pm

It's the biga$$ wire coming off the alternator and running back to your battery. I think it's inside some wire loom, but you know the one, you have to unbolt it to take the alternator off.

Hope thats the problem, at least then it's a cheap easy fix! :D

User avatar
slw240sx
Posts: 3308
Joined: Thu Aug 08, 2002 9:39 pm
Car: 1990 Ca18det 240sx Hatch

Postby slw240sx » Wed Jul 24, 2002 4:34 pm

mine was making my windshield wipers turn on and off intermitenly.. turns out my batt cable had poped off and the alternator wasnt provinding enough current to soley run the car also the car was sputtering and backfiring and then wouldnt rev over 2k

Thesil
Posts: 140
Joined: Mon Aug 26, 2002 7:24 pm

Postby Thesil » Wed Jul 24, 2002 4:34 pm

Yes it is the problem it just popped off....

uh where do i get a new one?

User avatar
djtodd
Posts: 150
Joined: Sat Mar 15, 2003 9:41 am
Contact:

Postby djtodd » Wed Jul 24, 2002 4:34 pm

You should be able to get a big ring terminal from any napa/auto parts store. If not, try a local stereo shop. They use large wire for system installs, when mine went that's where I got a new ring terminal.

Hope ya get everything working!

User avatar
f8sjester
Posts: 281
Joined: Thu Feb 13, 2003 2:21 am
Contact:

Postby f8sjester » Wed Jul 24, 2002 4:34 pm

heh. . . ok, if it ever comes down to thinking my car is possessed or something then the first thing i'll do is check my alternator and wiring heh. . it's amazing what kinda weird a** gremlins can be caused by simple electrical problems. . .

240SXer
Posts: 1559
Joined: Thu Sep 12, 2002 10:12 am
Car: 1995 240sx SE (2jz powered)
Contact:

Postby 240SXer » Wed Jul 24, 2002 4:34 pm

Mine is doing that exact thing with the airbag light. I had to take off the alternator yesterday because the bolt that holds it on broke and it snapped the tensioner bolt off inside the alternator. I put it back and everything was fine. But now the airbag light/amp light/ and the brake light are coming on intermittenly. I hope it has enough for me to get home because i'm at work about 30 miles away from home. What should I check? The red wire? There is a chance that I didnt put it back tight enough I guess. What should I do?

Thanks,

David.


Return to “240SX Technical Forum”