91 Ka24de Idie issue.

Information on the naturally-aspirated KA24E and KA24DE engines.
Grimreefer721
Posts: 30
Joined: Mon May 19, 2014 1:11 pm
Car: 1991 240sx s13
*KA24DET

2014 Altima S
Location: Oklahoma City

91 Ka24de Idie issue.

Postby Grimreefer721 » Sun May 01, 2016 4:49 pm

So it will fire right up and will idle for maybe about 15-20 seconds tops, and then kinda like shake and miss almost it sounds like and die, and if I try to give it gas no matter when after its started it immediately dies. Any ideas? It's a brand new tank cause mine was trashed and a new pump, and I cleaned all lines throughly. I've tried two differnt Mafs and neither made an improvement


Timothy S
Posts: 109
Joined: Sun Sep 28, 2014 2:29 pm
Car: 1998 Nissan Altima GXE, Auto RE4FO4A, KA24DE Engine
Location: Dallas, Texas
Contact:

Re: 91 Ka24de Idie issue.

Postby Timothy S » Thu May 05, 2016 10:11 am

Is it running rich or lean? You should smell un burnt fuel in the exhaust if its getting too much fuel. If it isn't getting enough fuel, you can also test fuel pressure looking for 43 psi on the fuel pressure gauge. Might be low fuel pressure, since you cannot rev it above an idle.

Grimreefer721
Posts: 30
Joined: Mon May 19, 2014 1:11 pm
Car: 1991 240sx s13
*KA24DET

2014 Altima S
Location: Oklahoma City

Re: 91 Ka24de Idie issue.

Postby Grimreefer721 » Mon May 09, 2016 7:21 am

No I haven't gotten to check fuel pressure yet, but it smells like it's running super rich, and I pulled the ecm this weekend to check codes and I got a 55 all system checks are good. So it's weird.


Return to “KA24E / KA24DE Forum”