2019 everything lit up not starting

Discussion of Infiniti's amazing (and underrated) sport-luxury crossovers, the EX35 and EX37. For 2014, the EX series will be renamed QX50, in line with Ininfiit's new naming conventions.
ISH604
Posts: 6
Joined: Wed Jul 01, 2020 6:14 am
Car: 2019 Infiniti QX50 Sensory in Hermosa Blue
2007 Infiniti G35X Journey in Liquid Platinum

2019 everything lit up not starting

Postby ISH604 » Mon Dec 21, 2020 6:34 pm

Hey yall. Tried a topic before here. Only rogue one got back to me. Well here we are 7 months later. Been at the dealership for 4 days. They said it's some type of module problem. Anybody have this issue? Looking for any answer. Thanks for any ideas.


User avatar
VStar650CL
Posts: 1399
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Altima 2.5 SL, 2004 Altima 2.5 S

Re: 2019 everything lit up not starting

Postby VStar650CL » Mon Dec 21, 2020 6:39 pm

Might want to reference the previous topic or provide a more-detailed description. Lots of things can cause lights but no-crank.

ISH604
Posts: 6
Joined: Wed Jul 01, 2020 6:14 am
Car: 2019 Infiniti QX50 Sensory in Hermosa Blue
2007 Infiniti G35X Journey in Liquid Platinum

Re: 2019 everything lit up not starting

Postby ISH604 » Mon Dec 21, 2020 6:48 pm

Lots of things can, but all of the light lit up and then the car doesn't start. No prior issues.

User avatar
VStar650CL
Posts: 1399
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Altima 2.5 SL, 2004 Altima 2.5 S

Re: 2019 everything lit up not starting

Postby VStar650CL » Mon Dec 21, 2020 7:24 pm

Security lamp lit? Brake lamps working? "Click" from the engine box? "Click" from under the dash but not the engine box? Key button cycles normally or just "On" and then "Off"? "PRNDL" indicator works normally? "Press the brake" message in the cluster responds normally? Most importantly, any codes in the ECM and BCM?


Return to “Infiniti EX35 / EX37 and QX50 Forum”