2017 qx50 sonar not working.

A general discussion forum for G35 and G37 owners and a great place to introduce yourself to the NICOclub G-Series Forums!
jaxquest
Posts: 10
Joined: Fri Nov 19, 2010 7:37 am
Car: 2010 Murano LE

2017 qx50 sonar not working.

Postby jaxquest » Tue Oct 29, 2019 5:26 pm

I could use someone’s help. It's a 2017 Infiniti qx50 the car has sonar. Under the camera screen the sonar is blacked out. As well as towing and show camera when sonar activates. The car was hit in front and complete front bumper needed to be replaced. The rear bumper just needed to be reattached. Not sure if bad sonar. Small piece of harness missing from right side from sensor to washerbottle area. and the shop made the connection work. But sonar still not working. Al cameras work I give up. The cruise works but the distance don’t

59407642752__CC2A8EF3-754B-4D9E-AE54-0EA6A487D6A0.JPG


User avatar
audtatious
Moderator
Posts: 36942
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: 2017 qx50 sonar not working.

Postby audtatious » Sun Dec 01, 2019 11:08 am

If this was a collision that was fixed under insurance then it's up to the body shop to make sure all systems properly work. Contact them and have them fix it. If they won't then contact your insurance company about the issue and let them deal with the body shop. If you paid out of pocket and don't want to pay Infiniti to fix it then you will need to go through the FSM and trace/validate each component, starting with the sonar sensor in the front.


Return to “G35 and G37 General Discussions”