2008 G37s blowing fuses on blower not working

Discussion forum for body kits, repair, modifications, interior styling, Audio / Video and internal/external lighting.
gr8ride22
Posts: 3
Joined: Tue Aug 19, 2014 12:39 pm
Car: 2008 Infiniti G37S

2008 G37s blowing fuses on blower not working

Postby gr8ride22 » Tue Aug 19, 2014 12:50 pm

Hello I wanted to see if any had any experience with this before, my A/C blower fan is not working and checked the fuses on the fuse block by your left foot kick panel and the two blower fuses are blown , I checked around and people said to replace the blower/accessory relay but that didn't work it blows the fuse as soon as the car is started. I've read there is a AMPLIFIER for the blower fan that that could be the problem does anyone know about this?


User avatar
audtatious
Moderator
Posts: 36942
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: 2008 G37s blowing fuses on blower not working

Postby audtatious » Sun Aug 24, 2014 10:48 am

I've never had an issue with the A/C on mine at this point. I'd suggest digging through the FSM to troubleshoot: http://www.nicoclub.com/FSM/G37/Coupe/2008/

gr8ride22
Posts: 3
Joined: Tue Aug 19, 2014 12:39 pm
Car: 2008 Infiniti G37S

Re: 2008 G37s blowing fuses on blower not working

Postby gr8ride22 » Mon Aug 25, 2014 2:24 pm

I tested the Blower motor and it was bad, put in a new one and it works good now.

gr8ride22
Posts: 3
Joined: Tue Aug 19, 2014 12:39 pm
Car: 2008 Infiniti G37S

Re: 2008 G37s blowing fuses on blower not working

Postby gr8ride22 » Mon Aug 25, 2014 2:26 pm

also I disconnected the battery and the window didn't go up atomatically but I found the fix to roll them down all the way and then up all the way and hold the button for 10-15 seconds. it worked

User avatar
audtatious
Moderator
Posts: 36942
Joined: Sun Oct 27, 2002 5:31 pm
Car: 2017 Q60 Red Sport - 2014 Q50s AWD
Location: Stalking You
Contact:

Re: 2008 G37s blowing fuses on blower not working

Postby audtatious » Tue Aug 26, 2014 3:02 pm

Excellent. Glad you figured it out.

Saints4me
Posts: 1
Joined: Wed Nov 23, 2016 4:15 pm
Car: 2009 G37 Journey

Re: 2008 G37s blowing fuses on blower not working

Postby Saints4me » Wed Nov 23, 2016 4:32 pm

I have a 2009 G37 Journey. I just changed the battery and cabin filter and discovered both 15A blower fuses are blown
I replaced them twice and they blew as soon as the start switch was activated. I pulled the blower out and replaced the fuses and they are still good so I'm thinking it's the blower itself.

I put 12Vdc to the motor direct and it works? What am I missing? Could the motor still be bad?

Joey

User avatar
telcoman
Posts: 5631
Joined: Sat Jul 08, 2006 11:30 am
Car: 2016 Q70 Bye 2012 G37S 6 MT w Nav 94444 mi bye 2006 Infiniti G35 Sedan 6 MT @171796mi. 2013 Altima 2.5SV
Location: Central NJ

Re: 2008 G37s blowing fuses on blower not working

Postby telcoman » Fri Nov 25, 2016 9:02 am

Saints4me wrote:I have a 2009 G37 Journey. I just changed the battery and cabin filter and discovered both 15A blower fuses are blown
I replaced them twice and they blew as soon as the start switch was activated. I pulled the blower out and replaced the fuses and they are still good so I'm thinking it's the blower itself.

I put 12Vdc to the motor direct and it works? What am I missing? Could the motor still be bad?

Joey
Are you using an OEM cabin filter or something else?

If something else is it interfering with the blower motor?

Try without the filter or put the old one back for a test

Telcoman


Return to “G35 and G37 Interior, Exterior and Audio”