2007 M35 won't start [SOLVED - replaced iKey module]

Forum for Infiniti M35 and M45, and Nissan Fuga owners.
Amilliongyvers
Posts: 1
Joined: Thu Feb 20, 2020 9:33 am
Car: 2007 Infiniti M45S

Re: 2007 M35 won't start [SOLVED - replaced iKey module]

Postby Amilliongyvers » Thu Feb 20, 2020 4:39 pm

mental69 wrote:
Tue Mar 06, 2018 5:49 pm
I had the exact same problem at fusionchickenleg in my wife's 07 m35x. Lights come on, even radio and such, but would not turn over. did all the same things he did with no result. then found a video on youtube that identified the ESCL (Electronic Steering Column Lock) as the culprit. If this is the problem, you will see a yellow key signal on your dash. Tapped on the metal box on the steering column under the dash with a screwdriver handle while pushing the start button, and viola! Car starts right up.
That bugger locks and unlocks your steering column and communicates with the ilock system. For my wife's car, it didn't lock the steering wheel when it turned off, so next time around, it gave the ilock a "no go" signal and the engine won't fire. tapping allowed the mechanical portion of that actuator to move and give the ikey the proper signal.

based on what I saw in Nissan forums, I am going to experiment with cutting off the lock motor power feed once the car is in acc and unlocked. The steering will no longer lock, but it should still give the iKey the okay signal.
A proper fix for this requires the purchase of a $1200 part, and another 3-400 in labor, as the part is installed with break-away security bolts that have to be drilled out to remove. Infiniti will act like they have never heard of this problem, even though Nissan had to do a full TSB on a very similar problem with the 09 Altima which was leaving drivers stranded. https://www.youtube.com/watch?v=oOTh3PqYh20
Cheers.
Mental
Did you cut the power feed to the module? Did it work and which wire is it? Going through same issue, steering wheel is free but won't allow to start.


macexperts
Posts: 10
Joined: Fri Oct 25, 2019 2:47 pm
Car: m45

Re: 2007 M35 won't start [SOLVED - replaced iKey module]

Postby macexperts » Thu Feb 18, 2021 12:29 pm

jetster23 wrote:
Thu Apr 19, 2018 1:42 pm
Hey, new member to the group here with a 2006 Infiniti M45. I have also now having the same issue with my ikey lighting up and the car not starting. I also think mines is stuck in the open position because the steering wheel is free when the car is locked. I have tried everything from tapping to actually hammering, to actually almost cutting off my left finger *long story* on a attempt to get my car back working. I was actually in a little fender bender a couple days ago where someone hit my on my right side, bent my fender and bumper in and the car worked fine I was able to leave the accident scene and park the car at home, but I went out the next day to crank the car with no success. Had anybody found a fix or work around to this for our cars. I have looked for the fuse specifically for the escl but have no been able to find it. What about a part number and the current updated revision that they are on would be a great help to even look into replacing it. Thank so much :poke:
Jester how did you get this resolved? have same issue on M45 - the new part is dealer only item and very costly. Also I understand programming must be done if you replace this module? Does anyone know if a locksmith can do this programming? Used wheel lock units can be had much cheaper but not sure about reprogramming. I see EDBWOY hacked his units together to get it working would it be possible to buy a used wheel lock box and possibly put the same controller on it (presuming it's the mechanical aspect that is non-operational?) Also strangely the car stalled out and I noticed the ikey icon staying lit after it wouldn't start (before I was getting the push to start and just click problem intermittently for a long time I now presume the wheel lock was the culprit on that) ... ACC and everything works ... keyfobs open doors etc but you cannot crank. Unfortunately I puled the battery connector thinking maybe a reset of the system might let it start before I saw the ikey light. After tow I checked to see if any OBD codes were set and got U1000 CAN communications - (serial)... so would that mean that the computer isn't seeing this wheel lock module at all perhaps and the controller in it died (resulting in car shut down?) -- the wheel is NOT locking at all when car is off now - it did lock before it stalled and wouldn't start again - any input would be appreciated and thanks in advance


Return to “Infiniti M35 and M45 Forum”