2003 G35 replaced camshaft sensor now car won't start

The G-Series Tuning Forum is the place to discuss G35/G37 performance modifications and mechanical repair.
salena1973
Posts: 3
Joined: Mon May 07, 2018 6:17 pm
Car: 2003 Infiniti G35
Location: Phoenix, AZ

2003 G35 replaced camshaft sensor now car won't start

Postby salena1973 » Mon May 07, 2018 7:50 pm

Help Please! 2003 G35 here's my story I got the error code 0345 camshaft sensor bank 2 so I replaced it then got error code 0340 camshaft sensor bank 1 so I replaced it and immediately got error code 0021 camshaft timing over advanced. The car was running fine. I searched the internet and I read you usually get this code when your low on oil or oil is real dirty. I changed the oil still same code I also read somewhere that if I didn't buy genuine nissan camshaft sensors I could get this code so I got the nissan sensors and I replaced both camshaft sensor and now the car won't start. I got the error 0345 so I put the other sensor back in there and still no start. It cranks and cranks but won't fire. I did some troubleshooting to make sure the camshaft sensor connector was working and it gets power and ground. So I think the plug is good. I don't know what else to do. I have the next two days off work and I need to fix it. Please any help would be great. Thank you.


salena1973
Posts: 3
Joined: Mon May 07, 2018 6:17 pm
Car: 2003 Infiniti G35
Location: Phoenix, AZ

Re: 2003 G35 replaced camshaft sensor now car won't start

Postby salena1973 » Wed May 09, 2018 12:01 am

just an update I replaced the crankshaft sensor today now I am getting error code 0223 and 1224 and 0345. The car is acting different before it just cranked now it cranked for a minute and then all the lights went out in the dash and nothing

User avatar
telcoman
Posts: 5514
Joined: Sat Jul 08, 2006 11:30 am
Car: 2016 Q70 Bye 2012 G37S 6 MT w Nav 94444 mi bye 2006 Infiniti G35 Sedan 6 MT @171796mi. 2013 Altima 2.5SV
Location: Central NJ

Re: 2003 G35 replaced camshaft sensor now car won't start

Postby telcoman » Thu May 10, 2018 4:56 am

salena1973 wrote:
Wed May 09, 2018 12:01 am
just an update I replaced the crankshaft sensor today now I am getting error code 0223 and 1224 and 0345. The car is acting different before it just cranked now it cranked for a minute and then all the lights went out in the dash and nothing
With a fifteen year old vehicle if you are not following/reading the FSM and just throwing non OEM parts you are just wasting money, time, and unlikely to find the root cause of your problem.

Just my $.02

Telcoman


Return to “G35 and G37 Engine, Drivetrain & Tuning”