2003 350Z engine electrical issues help

Nissan 350z / Nissan 370z technical discussion forum: Maintenance, performance, installations, modifications, how-to's and troubleshooting.
camtrans
Posts: 2
Joined: Tue Jul 28, 2020 8:16 am
Car: 2003 Nissan 350Z

2003 350Z engine electrical issues help

Postby camtrans » Thu Jul 30, 2020 10:15 am

Hello NICOCLUB Members : New here so bear with me !!

2003 Nissan 350Z touring edition engine electrical issues after new engine install ...
completed tests all static grounds checked ohmed and continuity tested for engine sensor grounds and body to engine grounds come back good , IPDM ECM relay good but replaced with OEM New Relay .

We are getting a no fire @ cylinder # 3 and no pulse to injectors either , havnt noid tested injector harness yet but have ohmed and continuity tested the sub harness for injector #1 & #3 & VVT sensor plug comes back good ?

All cam and crank sensors good . We are leaning towards a bad ECU but are having no luck for a Pin out diagram for this 2003 car and having no luck locating in the service manual down load ?

All Timing set to spec and double checked as well , even went the smell test on the ECU with No Burnt Smell .....

Any help and advise for this conundrum of a issue we"re having would be greatly appreciated .
Im leaning towards ECU issue with this car but customer is requesting additional tests of ECU before being sent out to Module Express for repair ....
This is a OEM ECU with roughly 80,000 miles .

The car was towed in to shop for a engine misfire issue on # 3 , after scoping cylinder and compression testing engine extensive damage was done to cylinder # 3 hence replacement engine being put in . I want all the gremlins fixed before the car leaves our shop and have a happy customer with everything working .

Please advise and thank you for your help


User avatar
mrwrolguy
Posts: 83
Joined: Sun Nov 26, 2017 2:39 pm
Car: 2004 White 350z Touring Edition

Re: 2003 350Z engine electrical issues help

Postby mrwrolguy » Wed Aug 05, 2020 6:29 pm

trigger comes directly from ECM.... bad ecm or a bad harness... troubleshooting my Z I pulled the ECm got the service manual and traced each trigger for the coils its a pain but can be done. I got my ECM repaired by a place i found Ebay.. was like 120$ no problems after repair. also check your IPDM if I can remember correctly the triggers route through the IPDM I took mine apart it had lots of corrosion so I replace it.

camtrans
Posts: 2
Joined: Tue Jul 28, 2020 8:16 am
Car: 2003 Nissan 350Z

Re: 2003 350Z engine electrical issues help

Postby camtrans » Wed Aug 05, 2020 6:39 pm

Thank you very much for the help.your exactly right on ecm and triggers . I've traced and triggered and ohmed harness and came up with no com from ecm and high resistance at ecm pids . Also went thru ipdm and noticed same symptoms , ecm should be back in car tomorrow and will give a update . But betting on the ecm issue as well


Return to “350z / 370z Technical”