1995 240sx s14 cranks and turns, then dies and keeps cranking

Information on the naturally-aspirated KA24E and KA24DE engines.
cjmo
Posts: 3
Joined: Wed Jun 17, 2020 6:34 pm
Car: 1995 240sx

1995 240sx s14 cranks and turns, then dies and keeps cranking

Postby cjmo » Thu Jun 18, 2020 3:29 pm

Hi all
I have a 1995 Nissan 240sx (S14) with a KA24DE running in it with a J7 ECU, or a 1997 Automatic ECU. When I first got the car it was running but since, the head gasket blew and so I've replaced it. I've rebuilt the head of the motor and seem to have compression in each of my cylinders as well as spark with brand new spark plugs and coils. I don't think I'd hear the engine turn over a few strokes if it wasn't igniting properly. I've tried realigning my distributor twice and nothing seems to work. The error codes I have go as follows



13 (Engine Coolant Temperature Sensor) (I've replaced it and don't know why that's still not working, maybe wiring)
41 (Intake Air Temperature Sensor) (I haven't had one working previously)
42 (Fuel Temp Sensor) (Not sure about this one)
81 (EVAP Bypass vacuum) (The EGR has been deleted previously, don't know)
83 (Manifold Absolute Pressure Sensor) (This one I don't know how to fix, assumed it meant there is a vacuum leak somewhere)
84 (TCM Diagnosis communication malfunction) (Was told you get this error because it is an ecu for an automatic on a manual)
87 (EVAP Canister Purge) (don't know)
93 (EVAP)
13-2 (MAP/BARO switching valve) (No Idea)

Link to pics for context https://www.that dead forum/threads/19 ... nk.273854/

Let me know which sensors you think I should replace/how to bypass any codes
I've tried a new mass air flow sensor, it hasn't worked. 6487
I have the tubing tucked under the other tube to the opening under the electrical insulation covering the blue and yellow cable. 6488
The Pink labeled vacuum line farthest to the left comes from the IAC and is connected to a metal pipe on the intake with a blue plug on the other end, as seen as below. 6489

Any help would be much appreciated. It shouldn't be timing with the chains and cams as they were identical to how they were removed in previous pictures, as well as following manufacturer guides.


cjmo
Posts: 3
Joined: Wed Jun 17, 2020 6:34 pm
Car: 1995 240sx

Re: 1995 240sx s14 cranks and turns, then dies and keeps cranking

Postby cjmo » Mon Jun 22, 2020 8:41 am

So little update:

Got the car running, it turns over. Bad news is it bounces between 1000 and 2000 rpms and doesnt go over 2000 rpms. I'll be trying out that other MAF sensor later to see if it does the trick and makes it all work.


Return to “KA24E / KA24DE Forum”