08 g37s coupe 6mt brake light always on and slow running but can still engage all gears

A general discussion forum for G35 and G37 owners and a great place to introduce yourself to the NICOclub G-Series Forums!
Pbaxjoker13
Posts: 9
Joined: Wed Apr 08, 2020 10:29 pm
Car: 2008 G37 Sport 2dr. 87k miles

08 g37s coupe 6mt brake light always on and slow running but can still engage all gears

Postby Pbaxjoker13 » Mon Jun 15, 2020 9:45 pm

I came back after 2.5 weeks being away. Car was dead. Called triple A, they got my passenger side door open, popped the hood and took it a while to get jumped. Everything works, i can shift into all my gears including reverse. The clutch doesnt stick at all and i dont catch on anything when i am shifting through gears.
BUUUUUUUUUT Here's the kicker; its so god damn slow, its like, im in 6th gear the whole time type of feeling when im going through 1st through 6th. It takes forever it seems to get up enough speed to shift into each gear. its like its in limp mode but not type of feel.
My rear brake lights are always on now too, after i got jumped from Triple A, i pulled out every fuse thats on the passenger side corner by the windshield, fuse box, lights never turned off and it still runs and revs up and everything. Its just when i drive its waaaaay bogged down.
I spoke to a tech at infiniti he told me about some kind of plastic piece(s) that are above the brake pedal and how they brake sometimes. What is that piece called? How much do they cost? Is it a DIY type of fix for a beginner can do? What tools would i need?
Any help would be greatly appreciated, bc it literally drove perfect before i let it sit for 2.5 weeks and now, no bueno.


User avatar
AZhitman
Administrator
Posts: 70424
Joined: Mon Apr 29, 2002 2:04 am
Car: 72 240Z RB25, 63 Bluebird RHD, 63 NL320, 67 WRL411, 67 SPL311, 68 510 SR, 77 620 SR20, 89 Pao, 97 D21, 98 S14, 11 LS460L, 12 Titan 4x4.
Location: Surprise, Arizona
Contact:

Re: 08 g37s coupe 6mt brake light always on and slow running but can still engage all gears

Postby AZhitman » Mon Jun 15, 2020 10:02 pm

You have a broken brake pedal switch.

The ECU thinks you have malfunctioning brakes, so it limits power to prevent damage to the braking system.

The brake switch is easy to replace. Get in the floorboard (easier if you pull the driver seat), operate the pedal by hand. You'll see the switch.

https://www.amazon.com/CPP-Brake-Light- ... B01N5SO6I7

Pretty easy to figure out. If you can't, ask a local friend who's handy.

Pbaxjoker13
Posts: 9
Joined: Wed Apr 08, 2020 10:29 pm
Car: 2008 G37 Sport 2dr. 87k miles

Re: 08 g37s coupe 6mt brake light always on and slow running but can still engage all gears

Postby Pbaxjoker13 » Mon Jun 15, 2020 10:38 pm

AZhitman wrote:
Mon Jun 15, 2020 10:02 pm
You have a broken brake pedal switch.

The ECU thinks you have malfunctioning brakes, so it limits power to prevent damage to the braking system.

The brake switch is easy to replace. Get in the floorboard (easier if you pull the driver seat), operate the pedal by hand. You'll see the switch.

https://www.amazon.com/CPP-Brake-Light- ... B01N5SO6I7

Pretty easy to figure out. If you can't, ask a local friend who's handy.
Thank you so much, its greatly appreciated. I will check it in a week or so when im back at my car next weekend. Hopefully, that is the problem.


Return to “G35 and G37 General Discussions”