08 EX35 dead even when hooked to jumper cable

Discussion of Infiniti's amazing (and underrated) sport-luxury crossovers, the EX35 and EX37. For 2014, the EX series will be renamed QX50, in line with Ininfiit's new naming conventions.
MJF08EX35
Posts: 4
Joined: Thu Dec 23, 2021 8:46 am
Car: 2008 Infiniti EX35

08 EX35 dead even when hooked to jumper cable

Postby MJF08EX35 » Sun Jan 02, 2022 3:05 pm

My 2008 x35 started a few days ago just fine but then battery was low and I was able to jumpstart yesterday but today had absolutely no power of any kind for lights or anything when I tried to jumpstart it I still had no electrical power anywhere is there a main computer fuse blown or is something else


User avatar
PalmerWMD
Posts: 18300
Joined: Mon Apr 29, 2002 3:14 pm
Car: 2004 350Z

Re: 08 EX35 dead even when hooked to jumper cable

Postby PalmerWMD » Sun Jan 02, 2022 4:40 pm

MJF,

sorry to hear of your troubles.

Please be just a tad more specific in the problem description so our experts ( which is not me) can give you the best feedback.
-When you jumpstarted it yesterday where you able to drive it some distance?
- When you jumped it today. do you mean it didn't start or showed no lights internal at all?
- Where u unable to start at first, when connected to the jumper cable? Or that is did not stay running?
- When u connected the cables, from the other battery was the other vehicle running? Or you had a stand alone jump pack?

And while I am not one of the resident experts it does appear you may have blown a fuse or worse, it is easy to make an error in order of connection for a jumpstart or grounding incorrectly.
But I reserve judgment until some more details emerge.

macgiver
Posts: 1375
Joined: Wed Jul 04, 2007 10:21 am

Re: 08 EX35 dead even when hooked to jumper cable

Postby macgiver » Sun Jan 02, 2022 9:12 pm

A mistaken reverse connected jump will give these symptoms , where one or more fusible links blows,unfortunately . More info may help of course. Remembering accurately step by step what has occurred in each and every move you have made .

MJF08EX35
Posts: 4
Joined: Thu Dec 23, 2021 8:46 am
Car: 2008 Infiniti EX35

Re: 08 EX35 dead even when hooked to jumper cable

Postby MJF08EX35 » Mon Jan 03, 2022 1:47 pm

The day before the car was completely dead with no lights or any electrical items functions. I connected the jumper cables and made sure positive to positive and neg to ground and immediately the convenient lights came on and car started right up and I let it run for several minutes and everything worked fine but door locks acted funny locking on its own after I unlocked it. Next day the car was completely dead again and when i hooked up the jumper cables I could not get the convenience lights to come on when i opened the door. Car would not start and no electrical worked. Suggestions? Did I blow a main fuse somewhere?

macgiver
Posts: 1375
Joined: Wed Jul 04, 2007 10:21 am

Re: 08 EX35 dead even when hooked to jumper cable

Postby macgiver » Mon Jan 03, 2022 3:21 pm

Time for DC voltmeter checks of battery disconnected , then connect and measure at posts / along the cables. Then do 12Vdc " test lamp " for light on BOTH sides of ALL fuses , 1st , testlamp in ' off ', then testlamp them again in the ' run ' ignition position .
But a noticeable spark when reconnecting the battery ( full recharged ) sorta shows somethings "ON" and killing it overnight . Seeing those DC amps / milliamps is next needed test between neg. cable and Batt. neg.whilst they are temporarily separated just for this test.

MJF08EX35
Posts: 4
Joined: Thu Dec 23, 2021 8:46 am
Car: 2008 Infiniti EX35

Re: 08 EX35 dead even when hooked to jumper cable

Postby MJF08EX35 » Mon Jan 03, 2022 4:19 pm

Thanks for the help. Will get into this weekend and let you know what happens,.


Return to “Infiniti EX35 / EX37 and QX50 / QX55 Forum”