04 G35x sedan engine noise

The G-Series Tuning Forum is the place to discuss G35/G37 performance modifications and mechanical repair.
notstreetlegal202
Posts: 2
Joined: Tue Jun 02, 2020 6:06 pm
Car: 2004 G35X Sedan

04 G35x sedan engine noise

Postby notstreetlegal202 » Tue Jun 02, 2020 7:48 pm

Weird noise coming from passenger side engine. Thought it was the power steering pump, but after changing noise is still there. has 160xxx miles. No check engine light at all. Hear it during idle and when driving with no change in tone. Any help would be greatly appreciated.

YouTube link for video of sound:
Last edited by Rogue One on Wed Jun 03, 2020 6:02 am, edited 1 time in total.
Reason: Fix Link(s)


DarkMan2555
Posts: 14
Joined: Sun Mar 19, 2017 8:06 pm
Car: 2006 Infiniti G35 Sedan 5AT w/ 157k+ miles
Location: Florida

Re: 04 G35x sedan engine noise

Postby DarkMan2555 » Tue Jun 23, 2020 2:36 pm

Hi

I do not know for sure what the noise is, but I did notice in your short video that you have a coolant leak @ 27 seconds that looks like it is coming from either your radiator cap or the rubber hose that connects the coolant reservoir to the radiator cap. You might want to get that coolant leak fixed so that your car doesn't have the potential to overheat.
Anyway, back to the noise, it's weird how the pitch doesn't change while driving. Since it's really loud by the passenger side valve cover, I feel like it has something to do with a timing-related component such as the camshafts, or cam sprockets. I would take it to a Nissan/Infiniti mechanic ASAP to help you diagnose what the problem is, because whatever it is, does not sound good at all.

Best of luck to you

notstreetlegal202
Posts: 2
Joined: Tue Jun 02, 2020 6:06 pm
Car: 2004 G35X Sedan

Re: 04 G35x sedan engine noise

Postby notstreetlegal202 » Tue Jun 23, 2020 3:02 pm

Thanks DarkMan for the reply. I saw the puddle of coolant the next morning. It was coming from the coolant hose from the reservoir. Bought a new hose clap and that fixed it. Good catch haha. After I replaced the power steering pump I also had replace the drive belt at the same time. I brought a can of belt conditioner and put some on, and guess what!! the noise went away briefly. I then sprayed each pulley individually to try to isolate the noise. It was coming from the alternator. When I spray right on it, the noise goes away but then comes back after a few minutes of spinning. Its weird because I never had any dimming of lights, or when I accelerate headlights get brighter or any of those tail tail signs. I even removed both positive and negative cables off the battery when the engine is running and still alternator was holding power. I'm assuming the bearing on the pulley are done and creating the noise. I haven't changed it yet as I just replaced both valve covers due to bank 6 spark plug sea leaking. So I plan on changing it soon and hopefully that solves it.


Return to “G35 and G37 Engine, Drivetrain & Tuning”