03 FX45 p0308 Help

A forum for lovers of Infiniti's hot-rod crossover, the FX! In 2014, all FX models will be named Infiniti QX70, in line with Infiniti's new naming structure.
jonathane75
Posts: 3
Joined: Sat Jan 18, 2014 8:35 pm
Car: 03 fx45

03 FX45 p0308 Help

Postby jonathane75 » Sun Feb 02, 2014 5:02 pm

I purchased a FX45 about 2 months ago, and it had some issues but for the price I couldn't pass it up. So it started with a p0300, p0011, p0021, p0035 and p0308. I knew I had my work cut otu bc the previous didn't take care of it at all.

Thus far I have replaced the following; maf, valve cover, plugs, coil packs, crank case check valves (2), cam position sensor, vvt solenoid (2), vvt sensors (2), vacuum lines, and throttle body.

I have done the seafoam treatment to the tank, upper cylinder, and to the oil. Added an oil catch can to each side of the block. There are no longer any signs of sludge or any lifter or valve noise. Car runs really good but will get the random mil indicator w/ p0308 and thats it.

I can unplug the coil pack and the car doesn't stutter at all. I can jump coil packs from any other cylinder and it will work there, but not on cylinder 8. I checked with a test light to make sure there is a current to the coil and have power, though I haven't checked to see what the voltage might be.

I am out of ideas and just trying to avoid taking it do the dealership. Any help on this issue would be helpful. I'm pretty good at doing the work my self.


jonathane75
Posts: 3
Joined: Sat Jan 18, 2014 8:35 pm
Car: 03 fx45

Re: 03 FX45 p0308 Help

Postby jonathane75 » Sun Feb 02, 2014 8:06 pm

"I purchased a FX45 about 2 months ago, and it had some issues but for the price I couldn't pass it up. So it started with a p0300, p0011, p0021, p0035 and p0308. I knew I had my work cut otu bc the previous didn't take care of it at all.

Thus far I have replaced the following; maf, valve cover, plugs, coil packs, crank case check valves (2), cam position sensor, vvt solenoid (2), vvt sensors (2), vacuum lines, and throttle body.

I have done the seafoam treatment to the tank, upper cylinder, and to the oil. Added an oil catch can to each side of the block. There are no longer any signs of sludge or any lifter or valve noise. Car runs really good but will get the random mil indicator w/ p0308 and thats it.

I can unplug the coil pack and the car doesn't stutter at all. I can jump coil packs from any other cylinder and it will work there, but not on cylinder 8. I checked with a test light to make sure there is a current to the coil and have power, though I haven't checked to see what the voltage might be.

I am out of ideas and just trying to avoid taking it do the dealership. Any help on this issue would be helpful. I'm pretty good at doing the work my self."

I cleaned and then replaced the injectors as well.


Return to “Infiniti FX35 / FX45 / FX37 / FX50 / QX70 Forum”