TCS OFF and SLIP light on, rough idle, bad acceleration

A Q45 forum / Cima forum for the President of Infiniti's lineup. Brought to you by Infiniti Parts USA, your OEM source for Q45 parts!
ash10hunt
Posts: 37
Joined: Thu Mar 11, 2021 6:29 pm
Car: 1999 Infiniti Q45

TCS OFF and SLIP light on, rough idle, bad acceleration

Postby ash10hunt » Wed Jun 16, 2021 2:31 pm

I just finished fixing my leaky fuel injectors, and as I was taking it out for a test drive, I noticed my TCS OFF and SLIP lights were on. I've looked at other threads and haven't really found answers or similar symptoms. Randomly, when I'm driving, my rpms seem to be limited to about 1000, and I really have to floor it to get moving. It also has rough idle when at stop lights. I've seen other threads saying that it could be an ABS sensor, alternator, or speed sensors I think. But my ABS light isn't on like other people have had, and I got my alternator tested a few months ago and it was good. I'm kind of lost so any advice is welcome.
Thanks!


User avatar
VStar650CL
Posts: 2717
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: TCS OFF and SLIP light on, rough idle, bad acceleration

Postby VStar650CL » Wed Jun 16, 2021 3:55 pm

You'll get TCS and Slip lamps from just about any serious engine code, because the ECM stops sending engine speed and that makes the ABS throw a C1130 and go limp. Check your engine codes.

ash10hunt
Posts: 37
Joined: Thu Mar 11, 2021 6:29 pm
Car: 1999 Infiniti Q45

Re: TCS OFF and SLIP light on, rough idle, bad acceleration

Postby ash10hunt » Wed Jun 16, 2021 4:20 pm

Ah I see, I've had the 1320 code (ignition signal), but I didn't think it was related, thanks for the info!

User avatar
VStar650CL
Posts: 2717
Joined: Thu Nov 12, 2020 1:25 pm
Car: 2013 Nissan Altima 2.5 SL
2004 Nissan Altima 2.5 S

Re: TCS OFF and SLIP light on, rough idle, bad acceleration

Postby VStar650CL » Wed Jun 16, 2021 4:32 pm

You're most welcome!


Return to “Q45 Forum / Cima Forum”