RB Series 2 issues past 3500-4k

A forum for owners and fans of the legendary Nissan Skyline and Nissan GTR.
LAUR33L
Posts: 1
Joined: Wed Jun 07, 2017 1:57 am
Car: C33 Laurel

RB Series 2 issues past 3500-4k

Postby LAUR33L » Wed Jun 07, 2017 2:12 am

Idles great, free revs great, drives great until boost kicks in and at 3500-4K rpms. Fresh rebuild, but had the issue before. Only mods are Power FC, intake, exhaust and front mount. New plugs properly gapped, new coil packs, new fuel filter. I have a new TPS on the way, I think it's bad but not the cause. I think the stock MAF is good. I don't think it's a tuning issue because I put the stock ecu in and had the same results. After the rebuild I found the wastegate line and the other one off the charge pipe were backwards and I readjusted the IAC and TPS and that helped but not the issue.

I'm at a total loss. It seems like a misfire and just stops excelerating. I thought for sure it was the coils but that didn't fix it. I'm just replacing everything at this point piece by piece I'm hopes of finding the issue. I've been fixing the previous owners crap for almost a year now and the car is running at 95% please help me get the last 5!


ca18det_boy
Moderator
Posts: 1380
Joined: Wed Dec 24, 2003 10:47 am
Location: Homestead, FL

Re: RB Series 2 issues past 3500-4k

Postby ca18det_boy » Tue Jun 13, 2017 12:20 pm

based off of what you said I'm wondering if something goofy is going on with the wastegate and the motor is hitting boost cut.


Return to “GTR Forum / Skyline Forum”