HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Forum for Infiniti M37, M56 M35h Hybrid and Q70 owners.
David__Allen
Posts: 28
Joined: Tue Feb 05, 2019 6:42 am
Car: 2013 Infiniti M37xS - Current
2000 BMW 328i - SOLD
2004 Infiniti G35 Coupe - SOLD
2008 Lexus IS250 - SOLD
2003 Lexus IS300 - SOLD
Location: Chicago, IL

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby David__Allen » Tue Oct 20, 2020 5:31 am

emm3seven wrote:
Mon Jun 01, 2020 1:49 pm
DoN_BLaZe34 wrote:
Mon Apr 27, 2020 8:58 am
I finally pulled the trigger on this thing and have been able to get CarPlay to work both wired and wireless.
Has anyone seen pics or videos of CarPlay in action on the VL2? This has been the only thing holding me back from this upgrade.
I know I’m pretty late to the discussion, but I have a VL2 and have used both wired and wireless CarPlay. Getting it to work for the very first time is slightly annoying but after that it’s pretty seamless.

My issues with this unit are the sometimes very slow boot (5+ minutes) and periodic black screen on startup. The slow boot thing is weird... it sits at the non-animated “vline” splash screen and flickers maybe once a minute, until eventually I see the animation and it boots. Seems like it’s getting stuck somewhere, timing out, and retrying until it eventually works. And it does the black screen thing probably once a week, the only fix is to shut the car off for a while or unplug/reconnect the main harness which is super annoying.

GROM’s customer service is absolutely terrible.


Yoda's Master
Posts: 331
Joined: Tue Jul 10, 2018 11:26 pm
Car: 2012 M56
2009 370z
Location: Rock in the middle of nowhere

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby Yoda's Master » Tue Oct 20, 2020 8:34 pm

I agree that the black screen thing was super annoying. I haven't had to do that for a long while now. Supposedly there was an update that fixed it. Try see if there's an update available. If that doesn't work, then you might need to do a reset with the microsd card. Talk to customer service about getting the card.

jeaosos
Posts: 12
Joined: Tue Feb 25, 2020 6:17 am
Car: Infiniti Q70L

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby jeaosos » Wed Oct 21, 2020 7:57 am

When the black screen issues happens, you can press and hold forward button on cd player, and touch anywhere in black screen 6 times, it will reboot to recovery mode, then you can reboot vline.

David__Allen
Posts: 28
Joined: Tue Feb 05, 2019 6:42 am
Car: 2013 Infiniti M37xS - Current
2000 BMW 328i - SOLD
2004 Infiniti G35 Coupe - SOLD
2008 Lexus IS250 - SOLD
2003 Lexus IS300 - SOLD
Location: Chicago, IL

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby David__Allen » Wed Oct 21, 2020 8:01 am

WOW, thank you! That is seriously so much easier than trying to unplug the thing. How did you figure that out?

Brian35XR
Posts: 127
Joined: Sun Jul 20, 2014 8:12 am
Car: 2011 Infiniti M37x
2006 Infiniti M35x
2004 Infiniti G35 - Sold

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby Brian35XR » Wed Oct 21, 2020 8:22 am

David__Allen wrote:
Wed Oct 21, 2020 8:01 am
WOW, thank you! That is seriously so much easier than trying to unplug the thing. How did you figure that out?
Grom support.

I'm having a separate issue where Vline will freeze my cars factory console. This causes the factory buttons to become unresponsive, the audio to cut out, the heat goes on full blast but the orange lights on the buttons all shut off. The touch screen still working throughout this. Eventually after 1-5 minutes the console will unfreeze and the lights and audio will come back on. Anyone else experience this?

jeaosos
Posts: 12
Joined: Tue Feb 25, 2020 6:17 am
Car: Infiniti Q70L

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby jeaosos » Wed Oct 21, 2020 9:45 am

David__Allen wrote:
Wed Oct 21, 2020 8:01 am
WOW, thank you! That is seriously so much easier than trying to unplug the thing. How did you figure that out?
Actually I am a dealer of grom, and I need to solve some kind of issues for my client.

User avatar
Ilya
Moderator
Posts: 9468
Joined: Fri Apr 23, 2010 11:20 pm
Car: 2011 M56x but I spend a lot of time on my 2015 Kawasaki Vulcan S. Former owner of a 2007 M35x. Also take care of my wife's 2016 QX60.
Location: Tampa, FL
Contact:

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby Ilya » Sat Oct 24, 2020 6:45 pm

Good to know the tap 6 times trick, very nice.

Brian, I have not had the issue you are encountering in nearly 2 years of use.

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Wed Apr 28, 2021 10:33 am

Hey guy, I'm looking to do this install on my 2015 Q70, and was wondering did you experience any issues with the front cameras not working properly, or having to reboot the vline2 on a regular basis? I ask because I'm hearing this from another owner of a 2015 Q70

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Wed Apr 28, 2021 3:12 pm

satown210 wrote:
Sun Mar 24, 2019 9:37 pm
Yoda's Master wrote:
Sat Mar 23, 2019 8:23 pm
Can you switch between this and the oem apps?
Can you unlock and root?
One thing to note is that you will loose the USB in the center console.
they sell a retention cable so you can use the center console cable. I plan to use it.

User avatar
Ilya
Moderator
Posts: 9468
Joined: Fri Apr 23, 2010 11:20 pm
Car: 2011 M56x but I spend a lot of time on my 2015 Kawasaki Vulcan S. Former owner of a 2007 M35x. Also take care of my wife's 2016 QX60.
Location: Tampa, FL
Contact:

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby Ilya » Wed Apr 28, 2021 8:11 pm

The reboot issue was fixed with a firmware update like 6 months ago. As for front cameras, can't speak to that because my car doesn't have them but the car only replaces the iPhone input so it shouldn't have any impact on your cameras.

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Fri Apr 30, 2021 8:36 pm

Thanks for the feedback. Yeah, my model has the all around view system on it so it has rear, front, and side cameras. The guy I'm chatting with about it said when his front camera comes on, the vline2 is overlaying apple car play over his camera view. Said the reverse camera is working correctly. I find it kind of odd that the vline2 would have any impact on the cameras as well. Why would they interrupt the original connection at all when it is using the aux in Put for display? Very interesting. ;-)

DoN_BLaZe34
Posts: 1686
Joined: Fri Jul 23, 2010 4:40 pm
Car: 2007 M45 Sport - Sold
2006 FX45 - Traded
2014 Q70S 5.6 - Current
Location: Jersey

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby DoN_BLaZe34 » Fri Apr 30, 2021 8:53 pm

I have the VL2 installed in my 17 Q70L and have never had that issue with the front camera

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Fri May 07, 2021 9:27 am

Hey DoN_BlaZe34, So when you get close to something in front of the car, your cameras come on like they should and you can see the images on the screen clearly when the vline2 is being used?

DoN_BLaZe34
Posts: 1686
Joined: Fri Jul 23, 2010 4:40 pm
Car: 2007 M45 Sport - Sold
2006 FX45 - Traded
2014 Q70S 5.6 - Current
Location: Jersey

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby DoN_BLaZe34 » Fri May 07, 2021 6:00 pm

tswopejr wrote:
Fri May 07, 2021 9:27 am
Hey DoN_BlaZe34, So when you get close to something in front of the car, your cameras come on like they should and you can see the images on the screen clearly when the vline2 is being used?
That's correct

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Sat May 08, 2021 9:59 pm

YEAY!!! :-) Thank the Gods. I've been chatting with a guy who has our model and he says he's been having problems. Glad to hear it's random and not across the board. Now I will order. thanks for your input.

DoN_BLaZe34
Posts: 1686
Joined: Fri Jul 23, 2010 4:40 pm
Car: 2007 M45 Sport - Sold
2006 FX45 - Traded
2014 Q70S 5.6 - Current
Location: Jersey

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby DoN_BLaZe34 » Fri May 21, 2021 6:55 pm

Happy to help

tswopejr
Posts: 6
Joined: Sun Apr 18, 2021 9:48 pm
Car: 2015 Infiniti Q70

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby tswopejr » Tue Jul 06, 2021 10:16 am

Hello, has anyone tried mounting the GPS antenna under the dash? I found a spot, but its under the speaker grill and I wonder if that will interfere?

User avatar
Ilya
Moderator
Posts: 9468
Joined: Fri Apr 23, 2010 11:20 pm
Car: 2011 M56x but I spend a lot of time on my 2015 Kawasaki Vulcan S. Former owner of a 2007 M35x. Also take care of my wife's 2016 QX60.
Location: Tampa, FL
Contact:

Re: HowTo: Install GROM Audio VLine VL2 (NIS9VL2) Android Auto/Apple CarPlay Interface (2011+ Infiniti M/Q70)

Postby Ilya » Tue Jul 06, 2021 3:17 pm

tswopejr wrote:
Tue Jul 06, 2021 10:16 am
Hello, has anyone tried mounting the GPS antenna under the dash? I found a spot, but its under the speaker grill and I wonder if that will interfere?
I wouldn't recommend it...GPS antenna's work best with line of sight to the sky...(that's why the OEM one is on the top of the car)


Return to “Infiniti M37, M56, M35h Hybrid and Q70 Forum”