Horn working intermittently only 2011 Versa Hatchback

General Discussion forum for Versa Owners
jbay13
Posts: 2
Joined: Fri May 19, 2017 2:16 pm
Car: 2011 Nissan Versa Hatchback

Horn working intermittently only 2011 Versa Hatchback

Postby jbay13 » Fri May 19, 2017 2:29 pm

I can usually get one beep out of the horn then nothing for 15-30 minutes or more. Also it sounds weak and squeaky. I can go under the hood and wiggle the fuse/relay black box, with all the relays and it and it will beep several beeps and then it will stop and I have to wiggle or tap it again. The box is a bit loose as I can wiggle it back and forth. I took out the relay and it looked fine but you really can't tell. Maybe loose wires? Any ideas?


User avatar
Rogue One
Moderator
Posts: 7384
Joined: Tue Jun 14, 2011 10:15 pm
Car: 2011 Nissan Rogue SL
2012 Nissan Rogue SL
2012 Honda CR-V LX
Location: Florida, USA

Re: Horn working intermittently only 2011 Versa Hatchback

Postby Rogue One » Fri May 19, 2017 6:25 pm

I think you answered your own question.

User avatar
centralcoaster33
Moderator
Posts: 2772
Joined: Tue Apr 05, 2005 10:41 am
Car: 240SX #5-1997
Location: Central Coast, CA

Re: Horn working intermittently only 2011 Versa Hatchback

Postby centralcoaster33 » Wed May 31, 2017 3:47 pm

I agree. You can tighten up the connections by bending the internals of the clips and you can use dielectric grease for all the contact points to prevent this from happening again in the future.

wags69
Posts: 2
Joined: Sun Mar 04, 2018 5:40 am
Car: 2009 Nissan Versa
2007 Saab 9-7x
2002 Cadillac Seville STS

Re: Horn working intermittently only 2011 Versa Hatchback

Postby wags69 » Sun Mar 04, 2018 5:57 am

Check the wires to the horn itself. Had the same issue, and the connectors were bad. Cut the connectors off and strip the wires and wrap them around the horn posts and mine worked fine ever since.


Return to “Versa General Chat”